Lost 200 energy

I tried to delete a value widget and the energy did not regenerated! so i am 200 short and i cant replace the missing widget anymore.

You deleted a widget from home screen, or app itself?

just the value widget!

Did you delete Value Widget inside of Blynk app? Or on the home screen of your smartphone?

from inside the blynk app from inside a tab

because you don’t have any Energy left or because of a problem in the app?

because i have no energy left because the app malfunctioned and did not refund me.

Can you please describe the exact procedure you used to delete the widget and anything you saw on the screen at the time.

Was the 200 units part of the 2000 units allocated to you for free or Energy that you paid for?

@Liq Please try to logout and login again. This will make sure you are updated from server. After that, If you still believe there is an issue, pm details (account email and purchases history) to @Dmitriy He’ll refill your energy in case there was an error.

i deleted the widget by dragging it to the top of the sceen. part of the total energy was paid. i pmed @dmitriy and waiting…

so… last night 200 energy came back.i quess @Dmitriy restored it. since then all widgets do not update their value from the device.no change in anything from me. i connected device to serial monitor no errorrs. none widget is updating exept from the history graph widgets. device in blynk app seems online but. and again i tried to delete a gauge widget and to readd it incase that fixes the problem and again 200 energy was lost.
I think tha something is seriously wrong with my app and i request someone from the developers crew to step in because i think that the problem is not from my side.

More info would be nice. ios/Android? What version? Does logout help?

Android v 6 samsung galaxy tab, motorola moto g2. logout not changed anything. i even reinstalled the app and it didnt help.

So is hardware connected? What is serial output shows? Do you get any messages on app side?

during my second look ,to be honest energy problem is restored, but the widget update problem remains. from the app side my device appears online all the time. since Dmitriy didnt changed anything during the fix of my energy problem i ll get more data when i ll physically close to the device and i ll get back to you.

I just return your energy, However it shouldn’t have any effect on “work”.

I Connected my device to arduino IDE. No library update prompt. I visited the blynk url and downloaded the 0.4.4 and tools. Restarted IDE. Recompiled using the new library. Serial monitor… all normal, new library verified under the blynk logo… and nothing workkkssss!!! i am going mad here…exept from history graphs nothing else workss. in app the device appears contstantly online!!!
So i tried updating the auth token. Refreshed the auth token from the app (with the danger to loose 1000 energy from sharing). tried emailing the new token… nothing … after a minute or so the button turned to “sent” but no mail received until now. So i copied manualy the new token to my code ,recompiled, restarted everything and IT WORKS!!!..
I tried to be very thorough in my description inorder to help the developers undestand what the heck happened.
(new auth token just arrived to my mail)…
I ll be in touch if any UFO effect reappers.
I believe in blynk and i think it will become perfect through our contribution!!
Thanks alot

ps: no energy lost from sharing app during token refresh!

All this steps you are describing seems like “no connection”/“no internet” issue. Do you have stable connection? 3G/wi-fi? Did you use some additional settings? IP address? Maybe local server?

uno+esp8266 via softserial. worked good (not perfect ) for 2+ months. My connection is not the best but i didnt have that mess at the past. the last 24hrs nothing … device contstantly online at the app, no errors at the serial monitor and nothing updates except history graphs. untl i refresh my auth key. I guess something desynchronised… whatever…no everything works perfectly!