Local Server with Node Red - Works OK until Node Red stops then Server Logs flood with socket errors

I followed your instructions and all works fine, however for me, the main reason to host a server locally and offline was to be able to use the websockets (node-red-contrib-blynk-websockets).

I’ve used the same setup before on the cloud and everything is fine, was running for weeks. However when I try to do this on a local server, All works OK until node red stops. The socket then floods the log with errors until I can disable the config for the websockets in N-R and restart the service. My feeling is this is more to do with the node-red side than the server but that is only a guess.
I’m using
server 24.2 (same result with 24.1)
Unmodified server.properties file (other than usernames etc)
N-R config for websocket is ws://192.168.xxx.xxx:8080/websocket (also tried 8082 and changed the server.properties to match)

Any Ideas???
All im trying to do is monitor a 232 serial string incoming on the Rpi and push elements of that string out to my phone with Blynk, no other HW, Or any other suggestions that can work offline, Like I said before the cloud version works a charm…

This sounded like something you needed you own topic for assistance on (outside of the Tutorial topic). I have moved your post accordingly.

Hi Gunner,

Yep I should really of posted it here I suppose rather than cluttering a well written tutorial. Thanks

You said that you set-up the local Blynk server so that you can run websockets, but then say it worked fine using the cloud server for several weeks beforehand. Were you using Blynk websockets with the cloud server during this period?

Are you running the Node-Red server and the Blynk server on the same Raspberry Pi?


Hi Peter,

Originally N-R was being run on several different Pi’s (a 3, a B+ and a a zero w) all using cloud connection. and never noticed the issue with N-R web-sockets. It’s only after finally getting round to switching the server to a local server running on a zero w that i noticed this issue. Will try installing the Blynk server on a fresh install of a pi3 tonight and try N-R from both windows and the Pi and see what results I get.