BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

Local server with Fritz!Box port forwarding

Hello,

I wanted to setup a local server and still be able to access it from outside my network.
To achieve that, I forwared port 9443. If I want to log into the server with the Legacy app using the
myFritz address (“XXX.myfritz.net”), I cant get it to connect.

However, if I look up the IP in terminal using ping XXX.myfritz.net and use that in the app (so in the form of “XXX.XXX.XXX.XXX”), it works. Accessing the webserver via the myFritz address in a browser works aswell. Only the app does not connect.

Thanks in advance!
Sam

are you specifying the port too?

You aren’t stating whether this is being done while connected to the local network, or via a different or GPRS connection.

Have you considered using a different DDNS client like NoIP or DuckDNS and running an update program on your server?

Pete.

Yes, I used 9443

I am not connected to the same network as the server atm. What do you mean by

?
Sam

Your DDNS service needs to know what the current public IP address of your router is. This will change occasionally (or possibly frequently depending on your ISP) and will almost certainly change when you reboot the router.

I’m not familiar with the Fritzbox, but presumably you have to tell your router the details of the myFritz account you created and the the credentials to use when doing the update?

Pete.

The router and myFritz account are connected and work fine. I use the myFritz URL for all kinds of stuff.
Plus, I can use the myFritz address in a Browser to access the servers webserver.

I just tried to use the myfritz address in a sketch and uploaded it to a ESP8266.
It can communicate with the server just fine. Only the App does not like it.

Sounds like a strange setup to me.
I’d try a different DDNS service if I were you.

Pete.

I just tried dynv6.com, but it still doesnt work. I can access the webserver with a browser, but the app is unable to log into the server using a DDNS. Looking up the IP by pinging the DDNS and using the IP directly in the app works though.

Are you running the local server on a Pi?
Are you redirecting the packets to the internal IP address that relates to eth0 ?

Pete.

Yes, the latest server version.

Yes, I do. And it works, I can access the server via browser. The app does not.

And the IP doesn’t start with 10. 172.16. or 192.168.? Just making sure! :slight_smile:

Can you access the server via the browser from another network?

It shouldn’t be necessary, but using ZeroTier is an option.

Pete.

Yes! I am outside the network this whole time! I know I cant use a DDNS from inside the same networks as the server is in.
Accessing the server using https://XXX.myfritz.net:9443 in a random browser gives me access to the admin panel. But using XXX.myfritz.net in the app does not. Really weird :smiley:

Well, that depends on how good you are at configuring your router! :wink:

What if you use a browser on your phone, does that work?!

Remote access can be a b*tch :joy:

Yes, also works. Apart from Chrome warning me about missing certs, it works.