BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Local server problems

I’m using blynk local server for long time.
Last week I had to reset my router because of safty issues.
After that blynk app doesn’t connect to local server.
Wlan is same on both devices
Blynk app version 2.27.6 and server is started correctly on PC.


Is there anybody having a idea what’s going wrong?

Presumably your public IP address has changed and either you’re not using a DDNS service, or your DDNS update client hasn’t done its job.

Edited to add…
Or maybe your Blynk server doesn’t have a static internal IP address and it’s now using a different IP so your port forwarding rules need updating?

Pete.

1 Like

Public IP address didn’t change.
Blynk server has static internal IP address and it is used as local server data in Blynk app.
What’s about app version no and local server version?
Does that fit together?
I started server-0.41.6 and windows tells me 0.41.7.snapshot is started.

The app, server and library versions all work together so need to be synchronized, but if they aren’t you generally just get odd results when trying to use new widgets and features.

Can you ping your server from your phone?
What happens if you do a port scan, are the ports you’re using pen?
Have you double-checked your port forwarding rules?
Have you tried re-starting your router and your Blynk server again?

Pete.

I couldn’t ping my server from phone.
I change ip settings to be assigned automatically.
After restart it worked fine with new ip address.
Thanks a lot for your help.
Hanno

1 Like