BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Local Server Port 80

rpi
localserver

#1

Under Automatic Let’s Encrypt certificates generation, where it says:

You need to start server on port 80 (requires root or admin rights) or make port forwarding to default Blynk HTTP port - 8080.

…I’ve followed the instructions for Port forwarding for HTTP/S API, but all attempts to access port 80 internally or externally get redirected to the default BLYNK_LANDING value of https://www.blynk.cc.

Does the above statement infer anything beyond changing the http.port value in server.properties file to 80 and then running

java -jar server-0.39.5-java8.jar -dataFolder /home/pi/Blynk

Maybe I’ve just managed to stare at it too long - but could use some advice on getting port 80 to play nice. I couldn’t get the Let’s Encrypt stuff to work automatically, but installed a manually generated setup that is working correctly.


#2

That’s correct. Server doesn’t have any default landing page. Redirect means all is ok.

Why?


#3

Presumably because the selfhost flag interferes with the already running blynk instance?

There are similar errors already discussed in the forums, but I wasn’t able to find a resolution either.


#4

Not sure I understood you.


#5

Hi Dmitry. Can we make the redirect go somewhere else instead on blynk.cc? I mean everything else to stay as it is in server.config.

Thank you.