Local Server not working anymore

I have been using a local blink server for over 3 years now. On windows 7. I have two identocal ESP devices of which one is connected to the blynk cloud server and one to a local server.
Normally I connect my local blynk app on a tablet to my local server. Suddenly the local server has stop working.

  • In the beginning of the evening I could switch the lights on , but at the end I couldn’t switch them off again. And since I haven’t had it working
    -I swapped the 2 devices and they both work on the cloud server. The the devices are OK
    -I can login with the app to the local server . Which I confirm in th elog
    -The devices logs into the server. Which shows on the app and in the log
    -I have a node red server and when subscribing to the button pushes it switches when pressing the button in the blynk app
    -But it seems that the messages ae received by the server but not forwarded to the device
    -I also see message counter increased in the web server

I was planning to move the server from my old WIN7 PC to a newer win10 PC. So I installed jave 10 and moved the data folder to the new PC with the same symptomes. I.e. App logs in, devices registers but nothing happens on button pushes that has worked for years.

Anybody, any idea what could have happened?

So I was running version 32 of the server on Win7. After problems I upgraded to version 37.
Ad now I run Win10 with version 37

There is not quite enough to go on here… what changed before it stopped working (something changed… there’s always something that changed :stuck_out_tongue_winking_eye: )

You mention the Cloud server works OK… but Cloud and Local Server are completely isolated from each other, different login (even if you use the same name and password), different projects, AUTHs, IPs and ports… so that doesn’t mean much of anything.

What App version are you using?

What Library version is installed on the devices?

What ports are you using for the device sketches?

Exactly what Local Server version were you using last time it worked and what are you using now?.. There is five sub versions of 0.37.x alone.

And going from 0.32.x to 0.37.x is a BIG jump, so lots of changes could have caused this issue… so even though you say the problems started before you upgraded… I suspect the port changes to be the main issue, as HardwareServer on Port 8442 was removed back on 0.33.0. Now you need to use port 8080 in the sketches.

Well using the cloud versus my local server proves that my device is working OK.
I’m not doing anything with the system other than pushing the button to switch the lights on and off. I noticed a bit sluggish response the last couple of days but blamed my wifi router for that…I jsut stoppped working. I work in software development and I know there is not something like a mystery and ‘nothing changed’.
So I was suspecting the PC but I moved everything to another PC with the same result.
But I think you are right about the ports.I will double check these. Even though it stopped working before upgrading.

Upgraded my device and use port 8080 and it works.Really no idea what happened. But all is good.Thanks for the hint

Technical changes for technical reasons is my best interpretation :smiley: