Local Server fails to send Authorization code

Can someone please assist me with my Local server as I am stuck with the following problems which I have not been able to find answers for.
I have installed the Server twice into a clean Pi each time but I am unable, after logging in on the app, to send Auth number to the registered email, I am also unable to change the password in the Blynk app get the same error message namely
“Email was not sent to your login acc. Please check your network connection.”
Also I cannot get the server to auto start on bootup works fine if I manually start it with the
line command "java -jar server-0.29.2-java8.jar -dataFolder /home/pi/Blynk "

Have added “java -jar /home/pi/server-0.29.2.jar -dataFolder /home/pi/Blynk &” to the /etc/rc.local file without any success.
I also added " @reboot java -jar /home/pi/server-0.29.2.jar -dataFolder /home/pi/Blynk &" to the crontab -e file also no auto start success.

mail.properties as follows:


Did you allow gmail less secure applications? If you search on the forums I provided a link to that (it’s also in the documentation btw).

Did you do update-rc.d after adding it to rc.local? I’m not sure it’s needed. The better way would be making a little startup script and adding it to init.d/ (scripts also run around on the forum).

I did allow gmail less secure applications however this did not fully resolve the issue it was only after I renewed the email address with a new password that got the email got sorted out.

I Created script in /etc/init.d/LocalServer

java -jar server-0.29.3-java8.jar -dataFolder /home/pi/Blynk
exit 0

Made the script executable
sudo chmod 755 /etc/init.d/LocalServer
Tested it via sudo /etc/init.d/LocalServer start this worked via the command line however I could not get it to auto start.

The local Server seems to work ok so far except the auto start.
Will appreciate some help in getting the auto start on bootup

did you do the update-rc.d ?

Try using the full path to Java, e.g. /usr/bin/java -jar. Depending on your setup, crontab might not have Java in it’s paths. Check the path with:

~$ which java

I also encourage people to take a look at systemd.

Got the darn illusive thing resolved thanks to all you guys help the problem was traced to a omitted word in crontab I had
@reboot /usr/bin/server java -jar /home/pi/server-0.29.3-.jar -dataFolder /home/pi/Blynk &
having left out the java8 part.

should have read:
@reboot /usr/bin/java -jar /home/pi/server-0.29.3-java8.jar -dataFolder /home/pi/Blynk &
Which now works great

Auto start on boot now works. absolute CARELESSNESS on my part.
Thanks guys.