BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Local Server Data folder missing

Config:
Server: Raspberry Pi4 running Blynk Server, Mosquitto MQTT, node-red, node-red-contrib-blynk-ws
Device: nodeMCU programmed with Arduino app using MQTT library.

Programming:
nodeMCU programmed to send MQTT messages to broker.
node-red with blynk library takes the MQTT messages and sends them to Blynk server
node-red with blynk library takes messages from Blynk Server and sends to nodeMCU via MQTT
iPhone Blynk App successfully receives the data and displays ok - also button works to send message to switch LED on nodeMCU

So all seemed to be working OK – however there is no $home/Blynk/data folder so the Blynk charts in the app do not have any historic data.

(note I had previously successfully installed the Blynk server on another Pi and had it connected “directly” to the nodeMCU using the Blynk C library for the nodeMCU - in that case the Blynk/data folder was created for the project and the charts in the app worked ok)

Any ideas please why there is no $home/Blynk/data folder ??

Thanks

Have you followed these steps:

Pete.

Update — just re-programmed the nodeMCU with the Blynk C library to connect directly with the Blynk server instead of via MQTT and the data folder was created… so looks like there is something in the node-red-contrib-blynk-ws via MQTT which is causing this ---- however I don’t understand why as the MQTT message is being sent to a Virtual pin which has been set up as a chart in the app… (which is confirmed in the Blynk Server Admin page)

1 Like

Update… now understand what the problem was — as usual it was “user error” — I had actually modified the msg.payload and added characters to the string — hence Blynk was not able to recognise it as a number and this not record it in the /data folder.

Problem solved

Using Node-red as an “aggregation point” for multiple sensors to a single blynk page works well - esp with MQTT

2 Likes