BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Local server connects fine over WAN but *not* LAN

I understand this is likely not a Blynk issue, yet I’m on day 3 of looking for a solution and I’m still stumped. Hopeful someone might give me some ideas of what to try next…

As per the title, my local server seems fine when I use my phone to connect to my public IP from it’s LTE connection, yet when I try to connect from my local IP over WIFI the app doesn’t see the server. I’d really like to be able to connect both outside my house and inside… It seems this is the opposite of most peoples issues with local server setup.

I’m using 192.168.1.xxx : 9443 in the app. The admin page is able to be logged into via my computer and that IP. I’ve forwarded the ports for this pc (both 9443 and 8080). I can’t seem to get in via wifi on the public IP either (seems my router/modem doesn’t have NAT loopback options…?).

I’ve tried disabling my firewall on both my computer and my router (temporary). I’ve also disabled my antivirus… Still no joy.

I think the first time i set it up it actually worked over local IP but when I reset the server to update the mail.properties my local connection started failing. I’ve also noticed this issue happens with other apps such as my webcam streaming app… Yawcam can be connected to via public IP over LTE but not local IP over wifi.

I’m pretty lost, so any ideas or advice where i should be looking or what I should be googling would be hugely appreciated.

Thanks! - Sean

OK… feeling like an idiot now :smile:

Always seems as soon as I post asking questions I fix it myself. I’ll post the answer in case anyone else has my foolishness set upon them.

Turns out my phone was connecting over the guest WIFI account. I never noticed this and am not sure why it wasn’t on my main WIFI but it turns out that was why my phone wouldn’t connect via LAN. Switched to have both use the admin wifi and now it’s solid. Ah well… Humility served :sweat_smile:

2 Likes