Local Server and USB Serial

Hello everyone

I read the docs, forums searches etc and no luck, so finally going to ask on here. There is tones of information, but i can’t seem to find the missing piece.

I am trying to get local server up and running with a USB serial connection to hardware. I have so far:

  1. local server running stated by my command prompt output
  2. latest java 10 and server 0-36-0.jar
  3. Mega 2560 with Arduino_Serial_USB example (modified only for auth code)
  4. USB script works with blynk-cloud.com port 8442 (when i have code updated to appropriate auth token and other settings).
  5. Phone app connects ok to local server (Using Galaxy S8)
  6. Shows “Wasn’t online yet” for hardware status (makes sense since I know it isn’t connecting)
  7. Serial output showing auto code repeatedly
  8. Baud rates confirmed at 9600
  9. USB script bat file edited to match my ip of my server (confirmed ip - also tried computer name with same result)
  10. Same computer used for USB connection and Local Server

My result is reconnecting attempts with error:
"Connect<>: connect<“”, “8442”> ERROR Unknown error <10061>.

During the re-connection it shows proper com port and baud settings.

I have not been able to find a direct piece of information confirming it still needs to be 8442 port in the script - but all examples and videos i watched doesn’t make mention of having to change it. I did try various other numbers, 8441, 8443, 9443, etc with no luck but error changes to the Received EOF error also documented here in the community.

I had it up to this in the past, but was away from project and so came back and updated to latest versions and same result (Blynk library, java, server.jar etc).

Can someone lead me to the right direction at least? All i seem to find is either USB script problems (to the cloud) or Local Server problems (not starting), but not specifically what I am looking for with both.

Thanks in advance, your time is apprecaited


Port 9443 on the App and with Local Server use port 8080 on the Mega script (or in the USB-link case… in the .bat file)

Because it is port 8080, not 8442 :wink:


Thank you for your post - that was it! I believe it tried that before at some point, but likely had other issues I hadn’t yet resolved going on.

Truly appreciate your time!

1 Like