BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Local Blynk does not recognize the local user anymore

Hi there,
I have a local Blynk server installed a year ago on an OrangePi.
Today, when try to connect the Blynk app it tells that local user does not exist. I connected to Blynk server and *.User file is there. The size is 19450 bytes at this moment.
I connected to web interface with admin account and in the Users List tab - the profile is not listed, however if I go to Size of User profile - i can see the profile there.
I tried reboot the server several times, it does not help.
I even tried to use one of the backup files (in the backup folder) and still it is not recognized profile.

Please help !

Thanks

reading the text again, perhaps I should be more clear. I was working on Blynk project very often, the profile that I mention is not visible anymore and gives me “user is not registered” was working the day before …
Do not know what happened the user is not accepted and Blynk server does not see that profile anymore.

Thank you for any hint here,

Even i had faced the same issue a long back. I had kept my RPI3 aside for almost for 7-8 months(I thought I had lost it, but it was lying inside a bin full of other electronic boards).

Later when i used it to i was not able to login. It said “USER NOT REGISTERED” . I had written down the user name and password in a book, so i am sure i am not entering wrong credentials.

But as there was nothing much going inside the project(just a couple of button widget), so I did not think of it much and created a new user.

I have read that if an account on the blynk cloud is left inactive for over 6 months, the account will be deleted… I can understand they will have access to it so they will monitor and delete it.
But how come they can access the local server ?(only if it has been deleted by the Blynk team), Is there any timer ticking to delete the account after a set period of time ??

That won’t be what happened in the situation you are describing - which BTW is totally different to the one being described by the OP.

Pete.

If i am not wrong, he is trying to login to a old account on his orange pi. But the account does not exists… I also had the same problem. I was not able to login to the server. So if there is no activity will it self destruct ?

But can you tell me why i was not able to login ? Any weird reasons ?

Hi, thanks for your answer.
I do not think blynk folks access my local blynk server ;-). And since I have using actively that profile/user even one day before - it’s not a ‘cleaning’ procedure either, I think.
My guess it could be some size limitation maybe ? the project contain a lot of controls, and 3 boards.
Still digging for a fix.
If anyone else have other ideas, I would appreciate any help.

@Madhukesh, the OP clearly said that this was

so it is not the same issue.

Rather than trying to hijack this topic to discuss your own issue, I’d suggest that you start a new topic and provide sufficient details to allow community members to form an informed opinion and comment as appropriate.

Pete.

My guess would be that the SD card has been corrupted.
If you have another then try either restoring a backup of your old one (if you have one) or doing a clean install and installing the same version of Blynk server that you were before then copying the user folder across from the old card.

Pete.

Pete,
I have tried to restore everything on a different card. It does not work still. Bit desperate, but hope to get some clarifications from my previous message:

  • does anyone know if there is a limitation of objects - maybe I reach out the limit and that profile gets corrupted
  • how can I use one of the backups taken, I tried to restor by simply overwrite. Still profile is not recognized

Thank you

Server.properties has a number of settings that might be worth exploring…

user.devices.limit=xx (number of ‘boards’)
user.profile.max.size=xxx (in Kb)
user.widget.max.size.limit=xx (no idea what this does)

Pete.