BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Library 0.5.4 missing version.h

#1

Hi,

I’m new to blynk, not new to programming (arduino and others)
I installed the latest library 0.5.4 within the IDE.

I tried to compile some blynk example programs on ESPDuino(ESP-13 Module),
All examples fail to compile. Error: missing <version.h>

fatal error: version.h: No such file or directory
** #include <version.h>**

Even with the code below:

#define BLYNK_PRINT Serial
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

void setup() {
  // put your setup code here, to run once:
}
void loop() {
  // put your main code here, to run repeatedly:

}

When I installed the previous library 0.5.3 the error does not show. I did not yet test any blynk program.

What am I doing wrong?

Peter

0 Likes

#2

Most probably you have outdated Arduino Core for ESP8266. Please update

0 Likes

#3

I have latest core for esp8266 (version 2.4.0) but I have the same problem

0 Likes

#4

Are you sure? :wink:

1 Like

#5

Latest is currently 2.4.2

Pete.

1 Like

#6

Yeah got it…Thanks

0 Likes

#7

Hi!

I had the same problem, but after updated the Arduino IDE for 1.8.8 version was solved.

Happy new year!

0 Likes

closed #8
0 Likes