BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Keep getting the error in compiling…


#1

Sorry to jump on an old post but i just cant get this to work.
I’m trying to make a relay turn on and off a few times following a button press but keep getting the error in compiling…

Can someone tell me what i’m doing wrong?


[Solved] Getting a button to run a function
#2

Your issue is new… thus new topic :wink:

You are tying to put a standalone function BLYNK_WRITE() in another standalone function void loop()

Look at the various examples for proper code layout, etc.

https://examples.blynk.cc


#3

Nice one, All sorted, i tried that earlier… kind of… i tried all sorts in desperation but with dodgy formatting.
I now have an IOT Nerf Turret… long story
Many thanks :slight_smile:


#4

Nice… did you hack the motors (and use a motor controller) or run off of USB via some device that supports USB host?

I have an old USB turret that I was just looking at today… debating if I had the mental focus to try blynkifing it… but I am too sleepy (as usual), so just put it back on the shelf for another day. I would probably hack the motors as I don’t know the actual USB protocols (EDIT - I know they are out there… just haven’t looked at them in years).

image


#5

I’ve just shoved a central locking actuator on a relay to fire it for now… The Nerf gun is huge so for now pan and tilt has to wait.
At some point I’ll probably use some stepper motors along with a hefty rig, but it works great for now… It’s part of a mario kart style drone racing course I’ve made… adds a bit more fun to fpv racing :slight_smile:


#6

It needs a camera and auto targeting lock too…