Java Error

Hi All
This is my first time using a local server. Java is throwing lots of errors but the server seems to be up and running but very slow.

This is the error log.
2017-01-18 20:33:21,235 Log4j2-TF-1-AsyncLogger[AsyncContext@70dea4e]-1 ERROR Unable to invoke factory method in class class org.apache.logging.log4j.core.appender.RollingFileAppender for element RollingFile. java.lang.IllegalStateException: No factory method found for class org.apache.logging.log4j.core.appender.RollingFileAppender
at org.apache.logging.log4j.core.config.plugins.util.PluginBuilder.findFactoryMethod(
at org.apache.logging.log4j.core.config.AbstractConfiguration.createPluginObject(
at org.apache.logging.log4j.core.config.AbstractConfiguration.createConfiguration(
at org.apache.logging.log4j.core.appender.routing.RoutingAppender.createAppender(
at org.apache.logging.log4j.core.appender.routing.RoutingAppender.getControl(
at org.apache.logging.log4j.core.appender.routing.RoutingAppender.append(
at org.apache.logging.log4j.core.config.AppenderControl.tryCallAppender(
at org.apache.logging.log4j.core.config.AppenderControl.callAppender0(
at org.apache.logging.log4j.core.config.AppenderControl.callAppenderPreventRecursion(
at org.apache.logging.log4j.core.config.AppenderControl.callAppender(
at org.apache.logging.log4j.core.config.LoggerConfig.callAppenders(
at org.apache.logging.log4j.core.config.LoggerConfig.processLogEvent(
at org.apache.logging.log4j.core.config.LoggerConfig.log(
at org.apache.logging.log4j.core.config.AwaitCompletionReliabilityStrategy.log(
at org.apache.logging.log4j.core.async.AsyncLogger.actualAsyncLog(
at org.apache.logging.log4j.core.async.RingBufferLogEvent.execute(
at org.apache.logging.log4j.core.async.RingBufferLogEventHandler.onEvent(
at org.apache.logging.log4j.core.async.RingBufferLogEventHandler.onEvent(
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$

Can someone help?

Hello. Do you have some specific properties? What version of server do you have?


No special properties at all. I have tried it with and without the generic properties file and get the same result. I’m running server-0.21.7.jar

I’m also running:
openjdk version “1.8.0_112”
OpenJDK Runtime Environment (build 1.8.0_112-b16)
OpenJDK 64-Bit Server VM (build 25.112-b16, mixed mode)

Please create in same folder with jar with :

Does that help?

sorry, should be

That fixed the problem.

Thanks for your assistance.

FYI. I am running the server in a FreeNAS Jail. Jail version FreeBSD 9.3. So you can add that to the list of successful installs.

I ran out of things to try so eventually ‘moved’ the blynk server to my Paspberry Pi.

It was a bit of a mission getting everything moved to a new system. Basically has to start from scratch and recreate users and give all of my devices new token ect. I’m sure there is a better way to move servers but could not figure it out.

I still have a problem accessing the admin panel remotely but I thing that is related to SSL under the new Jessie version. Nice thing about Jessie, it come with Java pre loaded.

well, now everything works as expected.

I think the root of my problem has to do with the OpenJDK running in a FreeNAS Jail (FreeBSD).