(Issues connecting to Local Server on PC) Blynk server down? 14/03/2017

Cant login to App, but I can ping both com and cc servers.
FB login returns nothing
Trying to login using IP for local server. No luck.
Trying to change password. Server responds with my mail address not in the database?

why are you posting this in “Announcements” section?

Uhm sorry

What error do you see on login screen?

Firstly, I logged into FB with USB over serial to your cloud. All fine.
Then I logged out and tried to create a new account with IP address and port for local server.
If I add email and password I get,

“Sorry, Server can’t talk right now”"

Then, when I again log into cloud with FB, it sends referral to FB, all good and then on “ok” it returns to the APP but does not take you to your Blynk interface. Also, I need to remove the APP and re-install to enter my interface.

I am on IOS

What IP did you type? Was you in same network as your server?

I hooked up my arduino nano via serial on my PC. Got the local server to run successfully on my PC. But I cant create a new account using the IP option. I port through port 80 as it is the only port the local server accepts when I run blynk-ser.bat.

What do you mean? Where did you put this port?

I simply used port 80 as per the blink-ser.bat file…

set SERV_PORT=80 in stead of 8442. That seems to work? Should I rather check my router to allow the default 8442?

Thanks in advance.

In case you are using local server you also need to change this on server side. Otherwise it will not work.

So if I start the Java server, do I need to change port etc as well? Mmmm

And then run the blynk-ser file and then create new login for Blynk APP?

On Port 80, it works, on Port 8442, it does not, even though I set up port forwarding on router. Which IP do I use when setting port forwarding?

Connecting device at COM3 to…
OpenC0C("\.\COM3", baud=9600, data=8, parity=no, stop=1) - OK
Connect(“”, “80”) - OK

@Jan_Du_Preez First thing to realize is that Local Server is completely separate from Cloud server… Different accounts (even if you use the same email and password as Cloud Server). Also no FB login on the App side, just whatever email address and password you create and the IP address of your server (in your case the IP address of your PC - NOT your router) and the default port of 8442.

Make sure your iPhone is connected to your routers WiFi; without fancier port forwarding and such you will not connect to a Local Server from your phone’s cellular connection.

Keep the default port of 8442 in the blynk-ser.bat… your router should be fine with that as it is all inside your network anyhow. Set the IP to match your PC’s IP address (NOT of your router) and the COM port / BAUD rate to match that of your Nano.

Make sure your local server is running in the background… you can’t close the windows of either the Server (as far as I know) or the USB-link without shutting them off.

Once you create a new account, via the app, on your Local Server and make a new project, unless you have also set up email in your local server, you will not get any auth codes emailed to you automatically… so you will have to copy paste them from the app and somehow transfer that to your sketches (email yourself from your iPhone to your PC perhaps?).

Avoid ALL serial prints when using USB-Link and even comment out the #define BLYNK_PRINT Serial or you will have problems “connecting” your hardware to the server.

I would recommend you to setup everything on default ports and only after that change something. Right now I can’t tell you where exactly error is as you changed things I’m not aware of.