BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Is "allowed.users.list=" working?

rpi

#1

Hi,
Put the last version of the Blynk local server on a fresh rapsbian.
Working all flawless and put it on internet to manage it from remote.
Becouse security purpose id like to permit register only for user of my custom domain.

By first step try to put on server.properties this directive “allowed.users.list=@mydomain.ovh”. But complete a full registration with a @gmail address.
Next step was to put “allowed.users.list=admin@mydomain.ovh,me@mydomain.ovh”. But same result with a @gmail address.

Now a work around is to put in server.properties “initial.energy=0” so no one can register to use my server without permission, but 'i’m pretty sure some statement conflicting or is incomplete.

Here my conf

initial.energy=0
allow.reading.widget.without.active.app=false
user.message.quota.limit=100
logs.folder=./logs
user.dashboard.max.limit=100
lcd.strings.pool.size=6
server.ssl.key=/somewhereonmydisk/privkey.pem
webhooks.response.size.limit=96
hardware.mqtt.port=8440
table.rows.pool.size=100
terminal.strings.pool.size=25
admin.email=XXXXXXXXX
admin.rootPath=/somewhereonmydisk/admin
user.widget.max.size.limit=20
listen.address=
blocking.processor.thread.pool.limit=6
stats.print.worker.period=60000
enable.db=false
force.port.80.for.csv=false
enable.raw.db.data.store=false
restore.host=blynk-cloud.com
csv.export.data.points.max=43200
restore=false
user.profile.max.size=128
allow.store.ip=true
allowed.users.list=XXXXXXXXX,XXXXXXXXX
allowed.administrator.ips=0.0.0.0/0,::/0
net.interface=wlan0
webhooks.frequency.user.quota.limit=1000
http.port=8080
web.request.max.size=524288
user.devices.limit=50
async.logger.ring.buffer.size=2048
user.tags.limit=100
server.ssl.key.pass=
admin.pass=
hard.socket.idle.timeout=10
product.name=Blynk
data.folder=/somewhereonmydisk/
map.strings.pool.size=25
profile.save.worker.period=60000
https.port=9443
log.level=info
server.ssl.cert=/somewhereonmydisk/fulchain.pem
force.port.80.for.redirect=true
notifications.queue.limit=2000
notifications.frequency.user.quota.limit=5

Blynk Server Block registration
#2

Hello. No. It was removed.


#3

Thank your for the fast answer.
It was replaced by others statement or procedure?
How can I prevent boot and crawler to create bulk users?


#4

Nope.

How can I prevent boot and crawler to create bulk users?

Right now you can only restrict access by ip or subnet mask.


#5

I want to use android app on my phone outside te LAN, cant restrict ip becouse is not alway the same.
I’m using it in the wrong way? Need to expose different port than 9443 for the blynk android app?
Can use of course a VPN but isnt really smart i want share the project with my family member…
So if you have any other advice im really glad to hear it

PS: sorry for my english, inst my language :frowning:


#6

Hello. No. It was removed.

Just another thing. Why it was removed?

PS: BTW your work is really god :slight_smile:


#7

Sorry to bump this thread but i had a similar question. Since i want to expose my Blynk server to the network i would like to have control who can register their account.

Is it possible to add something to disable registering in the future? A variable in server.properties would be nice.
Thank you very much in advance.


#8

Hope too becouse it will be more easy.

In the mean time i have setup a VPN on mi router to permit connection from mobile smartphone.

If you need to filter client from lan there is already a directive for ip filter
For other purpose you can use ufw to permit only know client or install openvpn and permit only the ip from vpn connection…