IP Config at the Admin Page

I’m configurating the “server.properties” on my local server and when I setup this way everything goes well to all PCs:
allowed.administrator.ips = 0.0.0.0 / 0

But when I set this:
allowed.administrator.ips = xxx.xxx.xxx.xx1, xxx.xxx.xxx.xxx2

Does not open on any PC. Someone has already passed by this? How can I solve this?

The / notation is networking.

Try to do like so: 192.168.0.0/24 (Assuming your network is the 192.168.0.x range, and yes, you can safely share that IP here, it’s private range and not routable on the internet :slight_smile: )

Thanks for the answer. I tried to access my admin page.
This: https://mc-casainteligente.ddns.net/admin “No-IP”

In the file “server.properties” I tried this:
allowed.administrator.ips = 192.168.xxx.xxx/24
“My WiFi router”

And this:
allowed.administrator.ips = 192.168.xxx.xxx/24,192,168.xxx.xxx

but without success

It probably needs your external IP address if you want to connect from outside your LAN, but I would highly recommend against making your Admin page available from the Internet.

If you really want, it can be done. Did you also forward the port from your router to the server for the admin page?

Yes, I connect through the external network.

I know why trying to filter the IPs: allowed.administrator.ips = 192.168.xxx.xxx/24,192,168.xxx.xxx

Não é “https: Admin” seguro? Se não, então, como pode ser ou não pode ser?
As portas e: 8441, 8442, 8443, 443-> 9443, 80-8080. Firewall Windows OK.

I don’t speak Portugese I guess? I can guess what you are trying to say though.

Can you start by trying to forward 9443 to 9443 internal? And try switching off the firewall, just for this test case.

Sorry for the english.
I don’t speak english. I can guess what you are trying to say though.
I have tried this: allowed.administrator.ips=192.168.xxx.xxx/31.
Firewall Windows: 9443->9443 Server.
CIRD_1

Unless you really know what you are doing, stay away from /31 subnets!

You know you can’t use “xxx” right? Try something like 192.168.1.0/24 instead (255.255.255.0). Also, it’s your router that should forward the connection, not the Windows firewall (assuming you don’t get your internet thru that machine?).

Take a look at https://portforward.com/

Thanks. I didn’t know. I’ll change.

Yes.
Yes. The firewall router is ok.
On the moment is everything in the same network via WiFi router. I also connect via external network by “No-IP” domain.

I can’t change my router IP to xxx.xxx.1.xxx.

I also received from him the IP xxx.xxx.1.xxx. By this reason I can’t set up my router because it’s work like a WiFi extender with the IP xxx.xxx.1.xxx

My router can only have the IP xxx.xxx.2.xxx. Can be this?

Eu tentei: allowed.administrator.ips =192.168.2.xxx/24, “PC Admin” mas não sucesso .

Your errors are not really Blynk-related as far as I can tell, it’s rather your network configuration and/or web server.

You should address these issues first :slightly_smiling_face:

:~$ curl -i -v https://mc-casainteligente.ddns.net:9443
* Rebuilt URL to: https://mc-casainteligente.ddns.net:9443/
*   Trying 189.124.71.183...
* Connected to mc-casainteligente.ddns.net (189.124.71.183) port 9443 (#0)
* found 148 certificates in /etc/ssl/certs/ca-certificates.crt
* found 597 certificates in /etc/ssl/certs
* ALPN, offering http/1.1
* SSL connection using TLS1.2 / ECDHE_RSA_AES_128_GCM_SHA256
*        server certificate verification OK
*        server certificate status verification SKIPPED
*        common name: mc-casainteligente.ddns.net (matched)
*        server certificate expiration date OK
*        server certificate activation date OK
*        certificate public key: RSA
*        certificate version: #3
*        subject: CN=mc-casainteligente.ddns.net
*        start date: Mon, 20 Nov 2017 19:07:48 GMT
*        expire date: Sun, 18 Feb 2018 19:07:48 GMT
*        issuer: C=US,O=Let's Encrypt,CN=Let's Encrypt Authority X3
*        compression: NULL
* ALPN, server did not agree to a protocol
> GET / HTTP/1.1
> Host: mc-casainteligente.ddns.net:9443
> User-Agent: curl/7.47.0
> Accept: */*
>
< HTTP/1.1 301 Moved Permanently
HTTP/1.1 301 Moved Permanently
< connection: keep-alive
connection: keep-alive
< content-length: 0
content-length: 0
< location: /admin
location: /admin
< access-control-allow-origin: *
access-control-allow-origin: *

Wow… How do you get this information? You can have access to my house?
No… Isn’t Blynk, Blynk is perfect. I love Blynk.
Seeing that I’m not a programmer I nee help about this questions. Can you help me?

Of course, who do you think is turning your lights off all the time? :sunglasses: Just kidding, I can’t access your house! In your reply to @Lichtsignaal , you posted the address, that’s all. But remember what he said:

but I would highly recommend against making your Admin page available from the Internet.

Well, neither am I :grinning: I’m not saying this because I don’t want to help you, but the… ehm… Blynk people wants the forum to be about Blynk, and not a general support for more or less unrelated issues. So they might close the topic for further discussion (just so you don’t get surprised if it happens).

That said, your problem is clearly a misconfiguration, presumably on your server (Microsoft Windows 2008?). If you look at the end of the info i pasted, you’ll see that location: /admin gives a HTTP/1.1 301 Moved Permanently reply. That I can’t help you with unless I have the computer in front of me. You just have to start Google like a b*tch :stuck_out_tongue_closed_eyes:

1 Like

Okay. Your response made me understand. Thank you.