iOS app not displaying string correctly

Using latest iOS app 3.5.6 (0). Micropython Blynk project.

Web browser Blynk page displays this (which is correct):

iOS app displays this (incorrect - missing the ‘- -’):

Code look like this:

blynk.virtual_write(3, "HWC Hot @ ", str(finishHeatingTimeTruma))

Because it displays correctly in the web browser, I think this is some iOS app issue?

Interesting… solved by changing the ‘,’ to ‘+’… unsure why the ‘,’ worked on the web browser version, but not iOS?

blynk.virtual_write(3, "HWC Hot @ ", str(finishHeatingTimeTruma))


blynk.virtual_write(3, "HWC Hot @ " + str(finishHeatingTimeTruma))

In C++ the code you are using would send the data as an array of values…

Not sure how that works in micropython, or why that array is displayed differently in the web dashboard as opposed to the app, but I’d suspect that it’s actually an issue with the way that the web dashboard widget works.


Thanks… any idea how this example is supposed to look on the browser or iOS app?

// Send multiple values as an array
Blynk.virtualWrite(pin, "hello", 123, 12.34);

I guess it depends what sort of datastream you’ve defined and what sort of widget you’re sending it to.

I’m not sure that there are any widgets that accept data in this format, and even if they are I doubt that there is an equivalent for both the mobile and web dashboard.

What exactly are you trying to achieve?


Hi Pete

I was just interested in the expected behaviour….
Using a “+’ worked perfectly for my application (joining two strings). Thank you, Andrew

For a widget that supports string datastreams then I’d expect the first field (field [0] ) to display in the first field of the widget, the second field [1] in the second field of the widget and so on.
If you send the data to a single field widget such as a value or labelled value widget - as you appear to be doing - then I’d expect the first field [0] only to display.

There aren’t many multi-field widgets, so that’s why I said…


Thank you… I was sending to display in a string field… I had not considered the universal nature the command… all clear now thank you for the explanation :slight_smile: