IOS App have not "+" button on the control bar on the project

I’m new user of blynk. I’m trying to create new project and to add some controls. But there are no “+” button on control bar. What’s wrong?

IOS 8.1.4

Nothing, just tap anywhere in the project and the screen will pop up :slight_smile: This is how to add widgets on IOS. It can only be done, logically, when the project is not running.

I tried. No result :frowning:
After some clicks the App crashes.

That’s how it should work. Is it possible for you to update to a later IOS? I think 8 is kind of old. Did you install/update the latest update of the Blynk application?

Also you can try rebooting your phone, for what it’s worth…

I use last version of Blynk app.
Reboot didn’t helped :frowning:
I cannot upgrade because my iphone is jailbroken, I use some helpful tweaks.

Hmm, ok. I’m afraid I can’t do much else than suggest this. Aren’t there any other possibilities to have your tweaks without a jailbroken phone?

If you really want to tinker with Blynk (which I can highly recommend) you can always download droid4x. It’s a free android simulator so you can install apps and whatnot. There are a lot of users on this forum who use it (including me) and it works really well.

I’ve just installed under x86 Virtualbox. There was a trouble with screen orientation, but resolved. Tomorrow I’ll begin to test.

Will blynk work behind http-proxy?

PS: one man from blynk team promised me to try to fix this problem (in another forum).

It’ll work behind a proxy I think, provided the proxy is configured in a correct way. I know ISA/TMG have lots of issues because they only allow SSL on port 443, so that could potentially be an issue if you are connecting to the cloud service with your Phone, but most modern proxies should be able to handle this.


And if someone promises to fix it, it’s 99% sure it will be fixed, The Bly k team consists of some awesome programmers and troubleshooters :slight_smile:

1 Like

@safari Look like we do no support jailbraked iOS. Sorry. Support is not planned.

1 Like

Thanks! Look like in that case we are in 1% :slight_smile:.

It could be anything, but I tend to agree on not supporting jailbroken devices. An IOS device is just limited. If you want full disclosure of your OS you should get an Android. They have pretty nifty phones, like the Huawei P8/P9 (awesome phone!!) or the Samsungs if you want to spend more money.

à propos.
Yesterday I tried to run blynk on ipad2 IOS 8.1, also jailbroken. It works without this issue.
So the problem is not in Jailbreak. I suppose problem with support IOS 8.1.4 and iphone 5s.

It could still be the jailbreak though. The interaction of all this software is very complex and sometimes you just can’t predict what goes wrong where.

1 Like

Hi! I have the same problem - app crashes after tap on black field. Iphone 5s, ios 8.1.2, no jailbrek.

Have you tried rebooting your phone and all updates installed?

Rebooting has no effect, latest version of the blynk

@Artem_S can maybe take a look than? :slight_smile:

Last thing I’d try is reinstalling the Blynk app. Could be worth a shot.

Temporary solution: I’ve installed android under VirtualBox and created blynk project with all need controls. Now I can run project under IOS app and even modify properties of existing controls.

BUT there are new problem. Changing properties at runtime on IOS App seems to not working (but working under android), for example:
//change LED color
Blynk.setProperty(V0, “color”, “#D3435C”);

2.5.10 problem solved, thanx, devs!

1 Like