BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Invalid token with HTTP RESTful API (on Local Server ;P )

I done refresh and got new token even it showing invalid token when executing

http://blynk-cloud.com/80d3631030d247f0b4250eecc2410849/isAppConnected

You are using the Cloud Server, correct? Not a Local Server.

Well I even tried your Auth on a NodeMCU (assuming the GEO DNS bit is a non issue now… says it is OK but I never tried before)… And I get Invalid Auth… so you must be doing something strange with the code.

Shouldn’t matter, but what version App… and Android or iOS?

Listen Gunner at first i imported code in nodemcu via arduino and run through blynk app it taking more time to come online so i started using custom mode in blynk app by placing my system ip address of 192.168.1.9:9443 in blynk app .
in Command prompt i run blynk server after getting started blynk server i log in to my account in browser by typing url of 127.0.0.1:9443/admin, in which i get auth as well as registered email.
now i imported arduino code of below using static ip address

#define BLYNK_PRINT Serial // Comment this out to disable prints and save space
#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] =“80d3631030d247f0b4250eecc2410849”;

IPAddress ip(192,168,1,32);
IPAddress gateway(192,168,1,1);
IPAddress subnet(255,255,255,0);

// Your WiFi credentials.
// Set password to “” for open networks.
char ssid[] = “S.R.Electronics Lab”;
char pass[] = “abcdef0123456”;

void setup()
{
WiFi.config(ip,gateway,subnet);
WiFi.begin(ssid,pass);
Serial.begin(9600);

Blynk.begin(auth, ssid, pass, IPAddress(192,168,1,9),8080);
}

void loop()
{
Blynk.run();
}

This is my nodemcu code which uploaded successfully. and came online and i executed my task.

But wheni try to execute in browser using http restful api i cant excute it by using same auth which is executed above.

Arrrgg :angry: … you have been using a Local Server Auth on a Blynk Cloud URL… Doh!!!

Use the IP of your server!!

This is what you get when you don’t read related posts :roll_eyes:… and what I get when I believe someone has an idea what they are doing :blush:

where should i use ip address of my server i mean in browser?
In this way 192.168.1.9/myauth/isappconnected?
i tried this it not working

Iam totally new to blynk and hardware core actually im Android Developer so plz dont make me feel down:disappointed_relieved::slightly_frowning_face:

If your PC (that is running the browser) is on the same network as your Server, then yes, of course the the Server IP is what you use… If you are tying to use your phone browser (on the cell network) or something connecting to the internet outside of your network, then you need to setup port forwarding and use your router’s Public IP & port

It is actually my mistake for assuming :blush: I figured that if you understood what an API was, and had the skills to setup a Local Server, then you probably wouldn’t use a internet URL for a local server in the first place… thus I figured you MUST be using the Cloud… my bad.

Iam runnning My PC and my Phone on same server , actually i want to write my own app by running this url back ground by using json object that why iam trying to run http urls direct gunner.Ok then my ip address of server is 192.168.1.9 so in which way i should execute in browser as u told above

I did mention that I don’t use this API stuff much, didn’t I :stuck_out_tongue:

After some searching around the forum… try this… and don’t forget the port, and the commands are case sensitive.

http://192.168.1.9:8080/<AUTH>/isAppConnected

I don’t think this forum is the best place to ask for advice about how to write what would potentially be a rival to the Blynk app, which piggybacks on the open source element of the Blynk product.
On second thoughts, given your lack of skills in getting the API to work with the local server, maybe the Blynk team don’t have too much to worry about :rofl:

Pete.

OK, OK… I think I already made this user sad… I think the coding skills are probably fine, but I would recommend more research efforts… here I am having to do all that for the user… and I don’t even use the API for anything :stuck_out_tongue:

Hey Gunner its working out hurrah !! thanks let me work if get further doubt i ping u

1 Like

I think this forum is the only place to get advice related blynk

Gunner all this commands are running

http://192.168.1.9:8080/80d3631030d247f0b4250eecc2410849/qr
http://192.168.1.9:8080/80d3631030d247f0b4250eecc2410849/project
http://192.168.1.9:8080/80d3631030d247f0b4250eecc2410849/get/D0
All above commands are running

But below commands regarding update through put and get are not working where iam doing mistake and im getting inturn wrong request format
http://192.168.1.9:8080/80d3631030d247f0b4250eecc2410849/update/D0?value=1
http://192.168.1.9:8080/80d3631030d247f0b4250eecc2410849/update/D2

https://community.blynk.cc/search?q=HTTP%20RESTful%20API

thanks for ur quick response:heart_eyes:

2 posts were split to a new topic: I have tried by changing values of pins by passing strings but it not worked plz help me