Invalid token when using HTTP RESTFULL URL

  1. I’ve set up a NodeMCU 1.0 board with Blynk. Works with the Blynk app on my phone.
  2. Tried HTTP RESTFULL URL both on the documentation console and my browser. Getting a msg “invalid token” checked the token for spaces. All good.
  3. Read the topics on the error and tried port, IP returned by ping with and without 8080 port specification. Same error still.

Any pointers to resolve this issue? TIA

What happens if you search this forum for this error?

Some say it is geodns problem and a few say using the IP returned by ping solves the issue.


It did not for me. Did I miss something apart from IP in those replies? Your message seems to allude to that.

My response return on the console also shows connected to Cowboy and not Blynk-cloud.

I am just making the only guess I could with the limited info you supplied… the issue could be that the device and App are not connecting to the same server… much depends on how your phone and board connect to the internet and so on…

Not a clue what you are referring to there.

The app is able to control the device well. So they must be connected to the same server. When trying to access from a browser, I’m unable to connect to the same server. The only hostname available is and I’ve no clue how that is redirected in the webfarm.

The docs section has a console where the commands can be tried in the HTTP RESTFULL section. That also fails to retrieve or set data for my token. Gives the same error “invalid token”. That return text shows the server connected to is Cowboy.

Sorry, I misread the RESTFULL part, I have updated your topic for clarity…

What is the exact command you are using?.. block out a middle part of the AUTH.

OK, got it now… you are playing around on a DEMO page :stuck_out_tongue_winking_eye: this is not actually connected to your project, or anything realy.

Use your Browser for the command.

I used the browser too. Used. The URL below:

Used variants with port numbers included and with IP too. Same result. Can share the token with you privately.

No sense… I am not well versed on the API use, so aside from checking the obvious (valid AUTH) and NOT using the demo page :slight_smile: I do not have any further ideas

Perhaps someone else will…

I used the same URL It worked. Don’t know why. Spooky…

Wish I knew why. Needs to be predictable. I don’t know if any changes were made in the DNS or otherwise. Would like to know that.

The IP varies from location to location. The day mine worked, I tracked the IP and have used it successfully eversince.

1 Like