Invalid HW cmd: 1 ERROR?

Getting the above when I open the serial monitor.

here’s part of the log:

[5620] Invalid HW cmd: 1
[5620] <msg 0,265,2

What does the ‘1pm16out17in’ mean?

using an ESP8266-12. I can post code if necessary.


@vshymanskyy do you have some ideas?

Can’t tell… looks weird that it prints 1pm16out17in…
Could you please post your code?

i get error like this

this the code

var Blynk = require(‘blynk-library’);

var AUTH = ‘55868c12b74f4dac8e8adf44e5cc*****’;

var blynk = new Blynk.Blynk(AUTH, options = {
connector : new Blynk.TcpClient()
var v1 = new blynk.VirtualPin(1);
var v9 = new blynk.VirtualPin(9);

v1.on(‘write’, function(param) {
console.log(‘V1:’, param[0]);

v9.on(‘read’, function() {
v9.write(new Date().getSeconds());


and i got error when user pin to high

You need to install onoff module to use direct pin operations (as suggested by the messages!).

still like this…
ohh please help…
when i use switch to turn on led

are you using iOS or Android?
I think we identified the problem, but need more details.

Android, iOS? What version?

Phone: Galaxy nexus, 4.4.4 cyanogen
mega + esp-01 - AT22SDK100-2015-03-20-boot1.2 ( powered aside)
right after “Ready” Invalid HW cmd: 1
and reconnect after few seconds.

other nano + esp-01 work fine

What about Blynk App version?

Blynk App версия 1.0 RC9

I am also getting the “Invalid HW cmd: 1” issue when using the example found here:

Here is the output I get:

8���������[206] Connecting to WifiNetwork
[2214] Connected to WiFi
[2215] My IP:
[2215] Blynk v0.3.1
[5001] Connecting to
[5410] Ready (ping: 5ms).
[5412] Invalid HW cmd: 1

We found problem. Will fix it today. Thank you all for reporting.

1 Like

For all who using Local Blynk server you can take latest version with fix right now. For those who using Blynk Cloud fix will be deployed in next 12 hours. Sorry for inconveniences.

Wow! Thank you! You guys deserve credit for being so open and communicative with your community!

I’m just getting started with Blynk, but if you guys are this awesome from the get go, I think I’ll be using Blynk as my primary IoT tool.

Thanks Dmitriy!



Sorry I didn’t follow up and post my code. But other users have and you’ve found the problem. I’ll test my case later today.


Should be fixed. Please check.

Yes, the error’s fixed