BLYNK
BLYNK.IO       📲 GETTING STARTED       đź“— DOCS       👉 SKETCH BUILDER

Invalid auth token - Python Blynk version?

I am trying the set-up Blynk 2.0 with python 3.9 on a raspberry pi 4. When I run the simple test code"usage example" that is copy/pasted from the github read me I get this:

    ___  __          __
   / _ )/ /_ _____  / /__
  / _  / / // / _ \/  '_/
 /____/_/\_, /_//_/_/\_\
        /___/ for Python v0.2.0 (Linux)

Invalid auth token

I installed the library with

pip install blynk-library-python

which I though was installing the 2.0 version, not v0.2.0 as indicated in the above blynk output message.

The invalid token message probably comes from a version mismatch but I failed to understand what I should do to install the 2.0 version.
Any help is welcome, thanks !

That’s right. You are using blynk IOT auth token with the old blynk library.
You have to manually install this file

and replace it with the one you’ve already installed using the " pip install blynk-library-python " command. after that your serial monitor should say " for python v1.0.0 (linux) " which is the new blynk library.
Capture

Thanks much John ! It’s kind of weird that what is described in the GitHub readme doesn’t install the right library… Also the usage example code of the readme doesn’t work. And it seems that the web dashboard doesn’t work either. But that’s OK, with the right code it works on my phone and this is what I needed, thank you.

1 Like

The " pip install blynk-library-python " command will install the latest version of the library. Go to GitHub and you will notice that the latest version of the library is 0.2.0, so the command does it’s job as expected.

Both mobile dashboard and web dashboard works fine, I tried both and didn’t notice any issue.

Are you aware that the web dashboard and the mobile dashboard are independent of each other?
There are a different set of widgets available in each, and in the web dashboard these need to be added to the template view and linked to the appropriate datastreams so that the dashboard can be viewed in the Device view?

Pete.

My mistake, evertthing works fine now.
Thanks for your help
-Henri