I'm not able to connect NODE MCU ESP8266(Amica) to Wifi Using Blynk. Can anyone help?

#define BLYNK_PRINT Serial

#include <ESP8266WiFi.h>
#include <BlynkSimpleEsp8266.h>

// You should get Auth Token in the Blynk App.
// Go to the Project Settings (nut icon).
char auth[] = "xxxxxxxxxxxxxxxxxxxxxxxx2361";

// Your WiFi credentials.
// Set password to "" for open networks.
char ssid[] = "Evolution";
char pass[] = "Next2309";

void setup()
  // Debug console

  Blynk.begin(auth, ssid, pass);

void loop()

@fantindominic please edit your post and add triple backticks at the beginning and end of your code so that it displays correctly.
Triple backticks look like this:

It would also be sensible for you to copy and paste your serial monitor output as well (also with triple backticks).


Serial Monitor Output:

12:16:54.821 -> $⸮⸮⸮⸮⸮⸮[75] Connecting to Evolution

@PeteKnight Thanks for the correction, I thought it was not required in this community. Hope I find my answers ASAP

Are you sure your SSID and password are correct?
They are both case sensitive.
Also, the NodeMCU can only connect to tge 2.4GHz band, not 5GHz.


Both ssid and password are Correct (network is 2.4Ghz)

Try rebooting your router and any repeaters you may have (if you do have repeaters then maybe keep them off and work near to your router, to reduce possible problem points).

Check that you have used the correct board settings when uploading your code.

Also remove any connections to the board, other than the MicroUSB cable.

If that doesn’t work then maybe your NodeMCU is faulty.