BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

IFTTT not working sith Blynk digital inputs

Hello. I’ve bought a Google Home Mini and I’m trying to make it work with Blynk. I am using IFTTT but it doesn’t seem to work with Digital Pins, only with Virtual Pins. Here’s the IFTTT config:

I also tried writing /pin/D1 and choosing PUT instead of GET, with body set to [“1”] but it doesn’t work. Any ideas on why this is happening?

Are you using a NodeMCU or Wemos D1 Mini?
What device have you selected in the app when you created your project?

I can’t remember exactly how it works, but there’s a chance that if you reference pin D1 then it may change pin GPIO 1, or the pin labelled D1 on the board (which are different with a NodeMCU/Wemos).
You should experiment with various settings (using GET preferably) and work-out the correct way of doing it.

Pete.

I am using a NodeMCU, but I’ve also tried with pin D3 of another mcu and I get the same result

I don’t really understand that answer.

Pete.

D1 (as shown on the board) is GPIO 5, so you would want /update/D5?value=1
D3 (as shown on the board) is GPIO 0, so you would want /update/D0?value=1

1 Like

Solved. Thank you both