BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

IFTTT makers error


#1

Hello Blynk Community

I am able to see/control/update a Digital Pin on my NodeMCU from a web browser. But when I try to make the same request from IFTTT makers channer I get an error “Action skipped” or “Maker Action error”. It´s not like it´s just with blynk server. I get the same error when I make a request to go to google.com. Can anyone explain why is this happening. Anyway I can put the URL

http://blynk-cloud.com/*****108448ca79061c3275/update/D14?value=0

Does this have to do with some server error of IFTTT makers channel?


#2

I don’t know if this helps you at all in terms of setting up your recipe in IFTTT, but this an example of my setup for Blynk/IFTTT. I share this because getting the syntax right took me some trial and error:

(FYI, this is for setup for when an old Android phone I’m using as a display runs low on battery, this triggers a relay to close to start charging.)


#3

Hello. Please try to use IP instead of blynk-cloud.com. Does that help?


#4

I tried last whole week to get work Blynk with IFTTT but no luck. I tried both put and get methods with browser,postman and maker channel.I always get invalid token message,how can i solve this?


#5

Hello. Try to use IP instead of blynk-cloud.com.


#6

Hi,I’ve tried already,somehow still doesn’t work for me.

http://46.101.143.225/ef416959e3024448a2f0c6664fe41b50/update/V0?value=0

says Invalid token.


#7

Please tell me your login email (you can send private message)


#8

I’ve sent PM :slight_smile:


#9

Hey Dimitri,

It worked!!! Thank you so much!


#10

Can you tell me what if I just want to send a pulse signal? like a push button. I mean to say, I want to set the value 1 and then 0? Is it possible?


#11

Yes. Why not?


#12

Can you please give me an example!? I’ve tried to look online, but I couldn’t get the answer.


#13

I tried IFTTT with the domain name and IFTTT compalins that it got 400 as response and after using the IP it works. Though with postman I can use domain name as well.


#14

This is because Blynk uses a number of different cloud servers around the world, to get good response times.

Your project and it’s associated Auth code are only stored on one of those servers, and this will be the one that’s nearest to you when you create the project (I think it’s actually a bit more complex than that, but go with this as the explanation for now).

When you use postman on your local PC, and specify blynk-cloud.com it hits the correct Blynk cloud server, so it works.

Assume that the ITTTT servers are on the other side of the world from you, and when they send a command to blynk-cloud.com they hit a different server to the one that your postman command hits. The blynk-cloud.com server that the IFTTT server hits doesn’t have your project on it, so you get an error.

The solution is for you to open a command window on your PC and type ping blynk-cloud.com
The IP address that’s returned is the IP of the Blynk server where your project lives. I you put this IP in your IFTTT recipe, rather than using blynk-cloud.com then IFTTT will be able to hit the correct Blynk server and will work correctly (assuming that the rest of your IFTTT recipe is correct of course).

Pete.


Voice comand with blynk
#15

This is also a 2 year old post!! so responding to someone’s “invalid token” issue is just a little too late :stuck_out_tongue_winking_eye:

@dejavu1987 Please take note of the time/date stamps when replying, thanks.


#16