BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

IFTTT and Blynk - questions

Dmitriy, thanks for the tip on the other post. I’ve done everything on ifttt and tried to activate V1 when i receive an email from myself but I am getting and error:
Maker Action Error
An error with Maker prevented your Recipe from working. Edit the Maker Channel or try again. If errors persist, visit the Help page for support.

Any ideas?

anyway, will try Automate for android.

Did you select PUT request? Correct body format ["1"]? Content type?

Yes, in both IFTTT and automate. None works

If I open the url in my browser I can see the button state, tough. So, nothing wrong with URL.

GET request (browser) is not PUT request (to activate V1)

I know that, I used PUT request both in Automate and IFTTT, I just tried GET on browser to check if URL was ok.

URL : http://cloud.blynk.cc:8080/MYTOKEN/pin/V1
METHOD : PUT
CONTENT TYPE : application/json
BODY (In automate “request content”) : [“1”]

Ok. Confirm. IFTTT doesn’t work for some reason anymore. I’ll investigate what is wrong there.

curl --include --request PUT --header "Content-Type: application/json" --data-binary "[\"1\"]" 'http://cloud.blynk.cc:8080/token/pin/d8'

CURL works fine. I believe something is wrong with IFTTT escaping… Cause it was working fine.

Works with the request “[“1”]” but not with [“1”]. Automate running :smiley:

Hi @Dmitriy

I have finally got back around to trying IFTTT and am not having any luck.
The IF is time based and the THEN is the maker channel.

URL - http://notmyreal.ddns.net:8080/blynkauthtoken/pin/V30
method - put
content type - application/json
body - “[“1”]”

I get the error… (on IFTTT)
Unable to make web request: Error: ETIMEDOUT

My Local server runs on a raspberry pi behind a router. I have setup port forwarding on the router to send any traffic on port 8080 to the Blynk local server IP (192.168.0.201)

Do you have any ideas why IFTTT is not working for me? I have tried sending different strings in the ‘body’ but have had no success at all.

1 Like

@NickMurray Hi. This is Blynk bug I fixed it already. I’ll do new release 0.13.2 with fixes today-tomorrow.

A new release of what?
Local sever?
iOS app?
Blynk library?

Just not sure what I will need to update. I am iOS user.

This is server issue

Ok, thanks. I’ll update my server

Hi,

Is Blynk working with IFTTT maker channel. ?

For me it still seems to be not working. I am using a simple DO button and put a value “1” to virtual pin V1. does not seem to be working ?

@RaPo what is your account? What IP ping shows for you?

Hi,

My account is raghu.ponuganti@gmail.com.
IP ping do you mean ping www.blynk-cloud.com from laptop…?
Unfortunately it shows “Ping request could not find the host www.blynk-cloud.com.”
I IFTTT URL I used http://blynk-cloud:8080/My authcode/pin/V1

Please try to ping blynk-cloud.com not www.blynk-cloud.com.

For IFTTT API try to use those API and tell me if that works for you.

Hi,
Here is the ping ip address : 46.101.143.225
For IFTTT I am already using only blynk-cloud.com …It still does not work.