IDE Arduino

Hi I’m new to blynk … I loaded an esrnpio first with my pc fixed with ide portable 1.6.12 and core esp 2.3.0 and it works … Then same code and same ide program I recharged with laptop but when I open the blink application and close it, it gives me offline notification when it’s not true at all. Use esp8266

did you change the auth token?

No I always used the same

and I’m assuming that you used verbose Serial.print and checked that to see whether the esp actually connected to the network? (and it did connect?). If that’s the case and you 've use the same auth, same code…then I agree its weird and potentially a bug. I would first check though whether the esp actually successfully connects to the network!

  1. upgrade the ide to 1.8.5
  2. stop using 2.3.0 esp core because it is buggy and obsolete. use 2.4.0-rc2 or 2.4.0
  3. what blynk lib are you using?
  4. cloud or local server?
  5. ios or android?
  6. what app version?
  7. post your serial debug here

It is not a serial bug … cone I said in the first post if I load with the laptop esp happens that when I open and close the app blynk I get the notification of the offline node when in fact it is not true because soon after I ping and the node is connected to the network and in addition the logic runs perfectly because it is a node for alarm … This is safe because even if the app notifies me the offline node when I simulate the presence on a pir sensor I still get the alarm notification … So this makes it clear that the node is connected … While if I load the esp with a fixed pc the offline status is not notified and as soon as I enter the app I immediately see the connection status ok

ah, ok. please pardon my intermeddle :wink:

there’s too much language barrier here. The above text will probably make perfect sense to you, but it doesn’t to me. I have no idea what you saying. Rereading it and adding punctuation will go a long way!

I repeat … My problem is as follows. I have 2 pcs a laptop and a desktop pc where they are installed IDE 1.6.12 portable and core 2.3.0 … If I load the esp with the laptop when I open the app blynk on android goes in connection and apprna close the app blynk tells me offline node … But in reality it is not true … If I load with the desktop pc instead this does not happen despite I have the same versions of IDE and core … The app does not signal me offline node and when I open the app the node is already online

ok I think I got it. Bottom line: if you load the firmware from your laptop it acts ‘weird’ if you load it from your pc it doesn’t. Correct?
‘acting weird’ means: the Blynk app tells you that the esp is offline while the ESP tells you that its actually online (I assume through the Serial.print/com port communication). Correct?

That can only mean that you laptop compiles the code differently then the pc! And that can have a LOT of causes. I would start out checking the compile settings for both. So menu–>tool–>
Board, Flash size, etc. etc. to see if they differ. After that you can consider removing all libraries from laptop and copy pasting them from your pc (so they MUST) be the same. If that too fails, call in one of the devs as maybe a bug??

until he deliberately uses an obsolete environment and refuses to provide the very basic info, it is unlikely that anyone can / will help…

IDE settings on desktop PC and laptop
as shown in the photo

CORE 2.3.0


On both machines turn on Verbose Output (File, Preferences, Show Verbose Output during: compilation and upload).
Compile/Upload the same sketch on both machines and compare each line of the compile and upload messages side by side until you spot differences.

My guess is that you are using different library versions on each machine and that will become apparent when you perform this test.


1 Like

Guys I solved thanks for your help … I deleted all the libraries from the laptop and I left only the blynk … Now everything works perfectly