I can’t connect to the HM-10, Invalid header type: 2

I can’t connect to the HM-10, it gets: Conecting… Connecting…

Not sure what your Invalid Header error is about?

But there are lots of recent topics about BT connection issues… check out this link…


I get this error after changue the NOTI to AT+NOTI0, before that, I have a OK CON PROBLEM. After testing I realized When I try to pairing in android settings and I left open the mensage : open the device app for pairing, I get the packet lost menssage, and OK CON PROBLEM, if not just get connecting, connecting,…

Android’s app’s beta 2.27.2 build has support for the latest library changes in BLE/Bluetooth - you can ‘join beta’ at Google Play page of Blynk app and try it.

Now It’s working, but I had problems when I wanted to become a tester. In Android 9 the option was not present.Hovewer I used other cellphone to activate the option,then installed in play store (Android 9.0).

1 Like

Wow, I’ve never heard about such issues - it joins beta on mine Pixel with Android 9. Thanks, we’ll investigate it.

1 Like

You can install the latest library version (from github master), which hopefully should fix the issue as well

Please switch to library v0.6.1, that also contains a fix for Bluetooth connectivity: https://github.com/blynkkk/blynk-library/releases/tag/v0.6.1

Thanks, now it works even I tried it with iOS and it works fine.