HTTPS API problem

hi, i’m trying to take the following[myToken]&dataStreamId=11&value=0
which works perfectly to curl from linux command line with no success.
i have used many formats that always return {“error”:{“message”:“Wrong request body”}} when ran,like in this case:
curl -H ‘Content-Type: application/json’ -d ‘{“value”: 1}’ -i ‘[myToken]&pin=V10

i’m not interested in posting the timestamp but the value to a Vpin (or the steamId, anyone).
do any one have successfully experienced with this (which should be trivial) and have the right format for the curl command line?
thaks in advace for your help.

Hello, @lricardi.

  1. Open Linux terminal and type in command line:
    curl --request GET

  2. For Batch update please read Update Multiple Datastreams Simultaneously - Blynk Documentation
    GET request does not have body.
    I think use in terminal:

curl --request GET https://{server_address}/external/api/batch/update?token={token}&{pin1}={value1}&{pin2}={value2}


Oleksii, thanks for your reply. I have tried it and it does not work, the message returned is {“error”:{“message”:“Wrong request format.”}}. Any type of troubleshooting that i can execute? Thanks again for your guidance

@lricardi please try with " " in request:

curl --request GET ""

Oleksii, it worked perfectly. Thanks so much for your help.

1 Like