BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

HTTP Restful API Write digital pin value to 1 does not working

#1

Hi
In the app everything is working very well but when I am trying to write 1 in data-binary to pin D9 using curl --include --request PUT --header “Content-Type: application/json” --data-binary “[“1”]” ‘http://cloud.blynk.cc:8080/xxxxxxxxx/pin/D9
the app button was turned ON but the physical port still OFF.

If the button and the physical port are ON the api works properly to turn OFF using this
curl --include --request PUT --header “Content-Type: application/json” --data-binary “[“0”]” ‘http://cloud.blynk.cc:8080/xxxxxxxxx/pin/D9

Where am I going wrong?

0 Likes

#2

Hello. This is server bug for digital PWM pins. It is already fixed and will be deployed soon. As temporary solution you may choose not PWM pin. Anyway thank you for reporting.

0 Likes

#3

Thanks Dmitriy, i will use another pin.

0 Likes

#4

@Claudio It is also already deployed. So you can use PWM also.

1 Like

#5

Thanks Dmitriy, i’ve tested and worked perfect. Nice job.

1 Like

split this topic #6

A post was merged into an existing topic: I have tried by changing values of pins by passing strings but it not worked plz help me

0 Likes