Howto for Raspberry Pi


is there a HowTo to get the library going on a Raspberry Pi?

I would like to report a “virtual port” on my Android phone


1 Like

I also had this question but for iPhone. Haven’t had a chance to dig into to it much.

@nvddussen, @Kamesan,

Sorry about forgetting to mention it, but it is documented here.
Please tell us if you have any further questions.

Happy Blynking!

1 Like


thanks for the link :smile:

wiringPi installed without a problem.

But the Blynk library gives a problem:

pi@rasp1-60 ~ $ git checkout
fatal: Not a git repository (or any of the parent directories): .git

What did I do wrong :smile:

Guess you are going to have a hard time now Blynk is hitting the not so computer literate like me :slight_smile:

I managed to solve the git problem I encountered.

What I did:

mkdir blynk
cd blynk
git init
git clone

and then the rest.


Next question:

How do I set a virtual value on the Raspberry Pi?

I working in Python and reading a DS18B20


We don’t have a Python library for Blynk yet. We’re already working on it.
With the native library (the one you compiled), you can only write in C/C++, same way as with Arduino.
And, control pins directly, of course.

1 Like

Having a problem installing wiringPi. Who would I contact about that? Fixed it to a certain point and now it said some .h libraries were not found. :frowning:


just post here what problem do have with specific exception log. It will help us resolve issue.

Are you serious?

I have to learn programming c to get blynk talking with RPi?

This sounds “slightly” different from your promise “build a app in 5 minutes”!

The minimum I need (and i think I am not the only one) is a simple example of how to do.
Some code examples and how to compile and start them.
How about the “Virtual” Pins inside the app? How do i use them?

A simple “hello where are live” is not enough!

Meanwhile I found some python examples in the library folder tests at github (

After playing around with the virtual ports, I ask my self how to get a floating point value (e.g. from an temperature sensor) in my smart phone app?
If it try to send a floating point number like 25.5 to V0, the app only shows 25.


We are working on tutorials and will be posting them in a while. We are a bit low on human resources. But still we work night and day to make your life easier.

Also, we promised direct GPIO control on Raspberry Pi. And it’s working exactly as stated in these instructions:

1. Connect your Raspberry Pi to the internet and open the console

2. Install WiringPi

3. Download and build Blynk:

git clone
cd blynk-library/linux
make clean all target=raspberry

4. Run Blynk:

sudo ./blynk --token=YourAuthToken

Which of these steps took you longer than 5 min? Let us know, we will be happy to help!


It’s a known issue, we are fixing it.

After trying with the “plan b” for wiring pi and ftp’ing the compressed file to my pi, it installed. Blynk installed too but I didn’t do the ./blynk yet because I forgot where my auth token was.

When all is said and done, blynk is working and my iphone app is connecting but it doesn’t really do much. At what point do I get readings and change things without using the server? Cant get the server part working yet.

@Kamesan, could you please first try using our server (the default one)?
P2P connections are really not supported yet.

I used the blynk cloud and the app / server connected but I’m not able to type in commands once the server is running. I may have had the wrong idea of what should happen.

I’m a french teacher ans i test Blynk with a raspberryB+. it controls a robot with 2 continous servo motors to move.
I followed the instruction and when i run blynk there is a problem :
invalid auth token.

What is the problem if you can help me!! :smile:
Thanks for your answer.


Have you put auth token?

sudo ./blynk --token=YourAuthToken

yes of course. When i put auth token i have these lines :
[0] Blynk v0.2.1
[10] connecting to
[173] Trouble detected : #flood
[5174] Timeout
[10174] connecting to
[10173] Invalid auth token

and the last two lines are repeated.
i don’t understand.

I will re-check this in few days…
Meanwhile, make sure you’re running unmodified main.cpp file and library files.

Anyone else having this problem?

Make sure when you paste your token there is not a space at the end of it.