BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

How to integrate Blynk and IFTTT (Google Assistant) for ESP01s

Okay what about the IFTTT ?

That’s exactly is my problem. What number of the pin should I use while writing the complete command in IFTTT. It’s to refer to gp0 of the Blynk

I’m not sure if you understood the problem. I’m able to control my device from Blynk with gp0 only. But unable to control the same device from IFTTT. I suspect that pin number is the key

Try D0.

Hi Buddy, That’s where I started using D0, the solution suggested by @Arsed, and found working for @slonline2000. The same solution didn’t work for me, though the problem is exactly similar. Just to give you more information, I have meticulously followed the steps enumerated given in the link below

If you can go through the link and tell me if I have missed any steps between fine lines, I’ll be grateful.

Impossible to say unless you share screenshots of your IFTTT setup.

When you ping Blynk-cloud.com what do you get?

Pete.

Hello @PeteKnight Nice to find a reply to my problem.


This is IFTTT screenshot. The IP address on ping is 186.166.206.43
Also the screenshot of the error when checked in ACTIVITY

Hope you find a solution

Use get method instead of put.

Partial screenshot, you’ve cropped the Body field off the bottom.
It appears that you’re using the GET syntax with the PUT method.

Personally, I’d always use GET and put the whole command in the URL field.

Pete.

1 Like

Your absolutely right, when use the put method if the body is empty or wrong, it’s not gonna work so you should use get method.

Greetings.

This screenshot is as per the link I gave above, which I followed meticulously. As per that PUT is advised and not GET. Notwithstanding the above, I have followed your advice and changed to GET. The complete screenshot including BODY is attached.
The system is still NO-GO, means not working

Paste the URL you are using in IFTTT into the address bar of a browser and hit return. The message you get in the browser will probably tell you more about the error than what you see in IFTTT.

Also, the documentation says that it should be “update” rather than “UPDATE”, but I’m not sure if that is an issue.

Pete.

I pasted the URL I am using in IFTTT into the address bar of a browser and it won’t open anything. There’s surely a problem, I feel, with URL, may be syntax error or Digital pin number.
I changed all caps to lower case for “update” but still no joy. Do you mind if you send me the complete list of steps for setting up in IFTTT so as to know if I have not missed any step.
Alternatively, you may give me the steps for setting up ALEXA in IFTTT
My BLYNK App operation is working super fine and facing no issues with that.

It’s not meant to “open” anything. You should simply see a response if there is a problem.
Forget the IFTTT side of things for now, getting the command working in the browser is the first step.
How do you know that the command isn’t working? What do you have connected to your ESP-01, and have you tried using value=1 in your URL and observing the result?

Pete.

Since you advised me to check URL pasting. I tried in 3 different browsers and the result is the same “Timed out”. That’s what I said earlier, won’t open anything.
I created 2 separate Applets; one to “turn on” and other to “turn off” with values 1 and 0 separately… So both values =1 or 0 are automatically tested.
Comand not working is from IFTTT screenshot sent earlier. Attached again.


Thanks for your efforts.

It would have been useful if you’d have said that you received a timeout message. Once again, pasting the command in the browser will never open anything, it will simply return a message. Telling us what that message is is important.

As I said earlier, you should forget IFTTT for now, and use browser commands to test your URL. You will need to paste two different commands, one which ends in a 0 and another that ends in a 1 to test turning your device on and off.

I’d like to see a screenshot of your app, along with the results when you ping blynk.cloud.com and the exact URLs that you are pasting into your browser (including the full Auth token - you can change this later).

I’m not interested in any mention of IFTTT or any IFTTT screenshots at this stage.

Pete.

@PRR

it’s 188 not 186, and update not UPDATE.

Thanks a lot :innocent: :+1: :pray:, @PeteKnight. You’re absolutely right and I have been making this mistake for a long. It’s now working as you have a keen eye for the details. Just asking can I use the same command in ALEXA in place of Google Assistant in IFTTT. I’ll try it tomorrow morning. It’s nighttime here.

Yes you can use Alexa with the same url.