How to create SSL certificates on Windows 10


How do I create it, I’m running on windows 10 and I couldn’t find any sources on how to do it on Windows 10.
The application OpenSSL will only run on computer from Win XP x64 to Win 7 x64 bit OS running machines.
I have successfully started and connected my phone and hardware to the server, how do I change the domain address and make the website secure. I entered what my domian name needs to be on the line as , I changed the line on as contact.emal=MyEmailId , I enabled allow less secure apps setting and i started the server and the server doesn’t give the output as

Generating certificates


Have you opened port 80 on your router/firewall? And redirected to your server pc? I noticed that lets encrypt stopped working when I closed it so I reopened it.

that port on my computer is open and my pc’s firewall is permanently diabled

#hardware mqtt port

#hardware ssl port

#hardware plain tcp/ip port

#http, plain web sockets and plain hardware port

#secured https, web sockets and app port

this is a pat ofmy code, did I make any mistakes ? please let me know.

Doubt your errors are there

I port checked your dns Adress “
80 is open
443 is closed (default https port)
9443 is closed as well.

This leads me to believe that you have not configured your routers firewall and that could be the culprit

Make sure to use a static ip for your server pc and open and redirect

Port 80 to pc ip through port 80
Port 443 to pc ip through port 9443

This is my router portforward settings
My server pc has a static adress of

I have few question hopefull you can answer it

  1. Which type of server is the blynk server its it DNS or FTP or something else?

  2. My router has two port section just guide me what to type in it and tell me if i have typed anything wrong

this is confusing

  1. and finally what is my static ip, I will just type in my ipv4 address(my computer’s ip) in
    send me a link on how to enable a static ip

thanks for you help till now

this is what it says now after making the changes in the file

It’s not a DNS or FTP server those are other types. I do not know what category blynk server falls under.
It runs on java and uses a custom TCP/IP protocol.

Static IP you must(preferably) set in your router, As I do not know how it looks on your specific router I can’t help you right now. You need the MAC adress of your server PC aswell for the “identification”. Poke around your routers DCHP settings.
Static IP is a user choice, you can use the current one by opening command prompt and writing ipconfig /all
look for physical adress, that is your MAC
look for IPv4 address, that is your server pcs current local address

Your settings are wrong. Please try these and avoid misstyping, its port 443 not 433.

I did what you told me to do

my ip address

and I ran the server agian and got this error

Ugh my bad. I missed that in your server properties you use

#http, plain web sockets and plain hardware port

Do only one of these changes

  1. Change http port to 8080


  1. Change router portforward of port 80 to on port 80 instead of port 8080

Made the change to the but I get an error as

sorry for my inconvenience

I wonder if it has something to do with your port 443 reporting as closed

Because when I try my IP 443 is open. Maybe you could try rebooting your router. That might change your pc IP though.

can I open the port in anyway ?

That is what you did when you port forwarded. You opened a port.
Does not seem to have taken or your PC is blocking 443

then what should i do just restart the router ?

Try it. If everything is “unblocked” and it still is not working then I’m out of ideas.

If 443 is blocked or somthing, cani assign another port ?

It is something localy on your network or PC that is blocking port 443. There is no need to change it as it will likely move the issue to another port.

What is the brand and model of your router?

Its provided by the isp which is BSNL