Home screen widget stopped working?

Hi everyone,

Has anyone experienced any issues with their home screen widgets?

I’ve been using a home screen widget to toggle a button (controlling a relay on an ESP8266 board) for the past few months flawlessly. But a day or two ago the home screen widget stopped working. I haven’t changed anything on my phone.

Pressing the widget toggles it on the home screen, but the relay never switches.
If I load up the Blynk app and press the button there, it works perfectly.

I’m using a Pixel 2. I’ve removed and re-added the widget on Nova Launcher, and also added it to the stock Pixel launcher (where it can’t be resized - huge!). Neither action helped. Removing the widget didn’t return my 100 energy either.

Is it just me?



Hello. Please take latest app version 2.16.7. Issue should be fixed there.

That’s the version I’m running now with the problem.

Please share your button settings.

I hope this is what you meant. :slight_smile:

Thank, we’ll check. Have you tried to login to other accounts before this issue?

Removing the widget would not return the 100 energy, the app is showing up the confirm alert that energy would be nonchargeable. You could pm @Dmitriy with your login so he could return you this energy, while we are fixing the issue.

And also what hardware are you using?

I don’t have other accounts so haven’t tried others.
I read that deleting a widget returns energy, but that must have been from the early days. No problem though, it’s worth it. :slight_smile:

Still true today, with 2 exceptions Home Screen widget and sharing a project.

I’m using a generic NodeMCU board.

Ahh, thanks! I was reading it with “home screen widget” in mind so automatically assumed it was included too.

@eug do you use Blynk Cloud? If so issue should be fixed now.

Yes, and yes! It works now. What happened?
Thanks! :slight_smile:

1 Like

@eug regression during refactorings :frowning:.