HELTECwifi kit 32 rev 2 not connecting to Blynk server

Before creating the topic

  1. Search forum for similar topics
  2. Check http://docs.blynk.cc and http://help.blynk.cc/
  3. Add details :
    • Hardware model + communication type. For example: Arduino UNO with Ethernet Shield
    • Smartphone OS (iOS or Android) + version
    • Blynk server or local server
    • Blynk Library version
    • Add your sketch code. :point_up:Code should be formatted as example below.
    I am looking for help with the following issue. I am running a program developed with Arduino IDE in a ESP32 dev kit with Blynk IoT. As far as the unit is an ESP32 dev kit or in an HELTEC WiFi Kit 32 version1, it runs without any problem. I recently bought two Heltec WiFi Kit that happens to be revision 2. With the new version the program keeps trying to connect to the server (where it is the Blynk Cloud server or my local server).
    I tried a small example sketch to verify if the problem can be my app. I use the LED_Blynk example under Example/Blynk/Widgets/LED/LED_Blink. This sketch just turn ON & OFF a Led widget in my iPhone. Heltec version 1 runs perfectly, Heltec version 2 is unable to connect to the server.
    This is what I get when running the sketch

[3165] Connected to WiFi
[3166] IP:
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v1.0.0-beta.3 on ESP32

[3172] Connecting to
[8173] Connecting to
[13174] Connecting to
[18175] Connecting to
[23176] Connecting to

I also notice this message before the compiler upload the code

esptool.py v3.0-dev
Serial port /dev/cu.usbserial-0001
Chip is ESP32-D0WDQ6 (revision 1)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
Crystal is 26MHz

I dont know if it is relevant but the compiler does not recognize the chip as revision 2, but is is rev 2. Also the IDChip sketch reports revision 1.

Any suggestion will be great. Thanks

void loop()

Uninstall this and install 0.6.1 instead.


Peter, thanks a lot for taking your time. I did as suggested but no change.

[26] Connecting to Las Canteras
[2683] Connected to WiFi
[2683] IP:
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v0.6.1 on ESP32

[2689] Connecting to
[20950] Connecting to
[39457] Connecting to
[57964] Connecting to

What port are you specifying when you try to connect to your local server?


Port 8080 for the local server

Any hints that may help?

Does your server log give any clues?


Thanks for your reply Peter.
I run the server in a Raspberry Pi4, if I look into file blynk.log within folder /home/pi/logs
there is nothing recorded. If I run the sketch in an ESP32 then it records in the log file username & time of connection.

What happens if you compare the serial output from your working NodeMCU to what you’ve previously posted here?


Difference is that with NodeMCU is that it shows a successful connection. After many ant trials in rare occasion the Heltec board does connect and the code runs. See below the serial output. What is remarkable is the ping:215 ms. I am starting to wonder if the problem is the wifi connection of the board and not Blynk.

Apologies for all time taken. I found the problema has nothing to do with Blynk. Just running the Factory Test Example from HELTEC after introducing my network credentials it does not connect to wifi.
Thanks for all your support.

1 Like