Help with project since Server 0.33.0 upgrade

My environment.

Photon device compiled with 0.5.0 library. 0.5.1 not available. Removed from project and re-added but 0.5.0 is the only one there.

Running local server-0.33.0-java8.jar which was updated last night. After reboot Photon could not connect

Running Android client 2.19 with port 9443 and it connects to local server. But app has message that device is not connected.

Tried added default-port 8080 to device - nothing changed
Updated iptables no change.

Other Pi program using 80. are:

#hardware mqtt port
#hardware ssl port
#hardware plain tcp/ip port
#http and web sockets port
#https and web sockets port
#application ssl port

Blynk.log entries:
18:18:07.012 INFO - Found generated with Let’s Encrypt certificates.
18:18:07.906 INFO - Hardware SSL server listening at 8441 port.
18:18:07.910 INFO - Application server listening at 8443 port.
18:18:07.912 INFO - HTTP API and WebSockets server listening at 8080 port.
18:18:07.914 INFO - HTTPS API, WebSockets and Admin page server listening at 9443 port.
18:18:07.916 INFO - Mqtt hardware server listening at 8440 port.

What changed with the server upgrade yesterday?

Is the 0.5.1 library available for proton?

What do I need to do to make this work?


I moved you into your own topic as this might get lengthy :stuck_out_tongue:

Always go to GitHub and use the manual install method

And what port are you using in the sketch? Should be 8080


char auth[] = "xxxxxxxxxx";  // Cloud Server
char ssid[] = "xxxxxxxxxx";
char pass[] = "xxxxxxxxxx";
char server[] = "";
int port = 8080;
  WiFi.begin(ssid, pass);
  Blynk.config(auth, server, port);
1 Like

What did you upgrade from? Is this the first time you have needed to adjust all the ports?

Updated from server 0.32.2.jar. Rolled back to server-0.32.2.jar and everything works. So that confirmed the 0.33.0. jar was the problem.
proton with 0.5.0 lib
android with 2.19
local server back to 0.32.2

As always thanks for all your help.


OK, I updated the title and category I had given this… we will see what the developers say, or if they need for further info.

EDIT This is in the notes for 0.33.0 Are you sure you don’t still reference that port in some sketch or something?


I’m using the photon web ide and there isn’t a method to upgrade library. They only show 0.5.0. Maybe all this is a timing issue of software updates. Do you know to add?

Nothing to sketch defined. are:

#hardware mqtt port

#hardware ssl port

#hardware plain tcp/ip port

#http and web sockets port

#https and web sockets port

#application ssl port

Re-tested 0.32.2.jar works but 0.33.0.jar won allow the photon to connect.

Ahh, I see… OK, I know nothing about that, sorry.

@vshymanskyy have we released 0.5.1 for Particle?

@5310 as the quick fix you may add into sketch


before or after “include” section.

i have just tried 33.0 local server (from 32), and it is not working,

what is the “long fix” so i don’t have to update my 7 device sketches?


this is the fix that works if you just want to change the server side:

sudo iptables -t nat -A PREROUTING -p tcp --dport 8442 -j REDIRECT --to-port 8080

1 Like

@Dmitriy, this will not work if put on top of the sketch. It gets overwritten by Blynkconfig.h. Why library doesn’t use the #ifndef statement as it does for other #defs? I had to change the port in BlynkConfig.h


So…I’m lost.
What should I change after upgradeing the local server from 0.32.2. to 0.33.0?
I have one photon and several ESP8266 devices. No one is working after upgrade. If I revert to 0.32.2 every thing works fine.

I can confirm. I had to roll back to 0.32.2 to get things working too. Had added #define statement and it still didn’t work.

Particle will be updated soon

6 posts were split to a new topic: App connects to the server but devices always offline

Particle lib still not updated. 3/13/18

Thanks. looks like i missed it.

FYI, checked Particle’s web portal and 0.5.1 not there. I’m using their web compiler IDE not the desktop.