Help! Simple WeMOS D1 Mini LED project won't go on-line

Firstly let me introduce myself…I’ve used the “old Blynk” for a while and am confortable with it but this “new Blynk” seems to have a lot of bells and whistles which is good and bad but that’s life but as a newbie I’m quite unconfortable at this point. Before I get to my problem, please allow me to air two issues:

Issue 1: I’m not too familiar with on-line forums in general but I can see them as being extremely useful. It would be nice to have a FAQ about this forum as I’m not sure I’m “posting” this to the right area even. What is a “topic”, “topic list”, and “catagory”? How do post code? Not a complaint but just explaining my ignorance.

Issue 2: New Blynk, Old Blynk, Blynk 0.1, Blynk 1.0, Blynk 2.0, ??? I know this “version” is relatively new but consistancy would be nice. How can I search the web and refer to one or the other other version of Blynk uniquely?

Now to my problem; it’s probably something simple…or not.

Project: Sorta a “Hello World” project. To remotely turn an LED on or off with “the latest version of” Blynk. The dashboards consist of a single switch.

Hardware: WeMOS D1 Mini, initially had D1 connected to an LED with a series resistor to ground but I even removed that to try to resolve this issue.

I compiled/loaded the following code and it worked. Recompiled and reloaded the hardware and the web dashboard and app dashboard both show “off line”. I can’t get anything on-line.

// Fill-in information from your Blynk Template here
//#define BLYNK_TEMPLATE_ID           "something"
//#define BLYNK_DEVICE_NAME           "First MDS Project"
#define BLYNK_TEMPLATE_ID "something"
#define BLYNK_DEVICE_NAME "MDSfirstTemplate"
#define BLYNK_FIRMWARE_VERSION        "0.1.0"

#define BLYNK_PRINT Serial
//#define BLYNK_DEBUG

#define APP_DEBUG

// Uncomment your board, or configure a custom board in Settings.h

#include "BlynkEdgent.h"
const int   D1zzz = 5;  // GPIO.05=D1
   int pinValue = param.asInt();

void setup()


The captured serial line output the following after resetting the WeMOS D1 Mini:

___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v1.0.1 on ESP8266

[380] --------------------------
[383] Product: MDSfirstTemplate
[386] Firmware: 0.1.0 (build Jul 24 2021 20:55:35)
[391] Device: ESP8266 @ 80MHz
[394] MAC: B4:E6:2D:67:AD:25
[397] Flash: 4096K
[399] ESP core: 2.5.2
[401] ESP SDK: 2.2.1(cfd48f3)
[404] Boot Ver: 31
[405] Boot Mode:1
[407] FW info: 458880/3710976, MD5:695d912ed719adb1f23936bdf56fbcd3
[609] Free mem: 29872
[609] --------------------------
[1375] AP SSID: Blynk MDSfirstTemplate-0F300
[1376] AP IP:
[1377] AP URL: blynk.setup

please edit your post, using the pencil icon at the bottom, and add triple backticks at the beginning and end of your code so that it displays correctly. Triple backticks look like this: ```

Thanx! See, I learned somthin’ already!

Update the ESP Core to the latest n see if that solves your connection issue. Also try flashing erasing both sketch n wifi credencials.

When using Blynk.Edgent Dynamic provisioning, you should use your Blynk App to Add a device:

  1. Click Add Device in the right menu
  2. Follow the scanning/adding procedure

That’s it! SOLVED! I knew it would be something simple and that I am very new (and ignorant) of this new version. Thanx mucho! (and such a quick response - impressive)

Thanx for the idea but Sir vshymanskyy came to the rescue with something that I should have thought of…(sound of my palm hitting my forehead) !

Another strange thing now… after all was working I re-re-flashed the hardware to double check things and although everything works okay again, the app dashboard reports the device as “Offline” (as listed within the button icon) but everything is working fine! Weird! Blynk bug? Oh well!

Do you mean web or mobile app?

…the mobile app (application=program). The web dashboard is a page displayed by a web browser and isn’t an “app” – at least that’s the way I understand it… correct me if I’m wrong.

I see you’re a co-founder so here’s another issue that I’ve run across a few times already that really concerns me (and I barely operated this trivial project). There are frequent times when things are out of sync. The Mobile App shows one state and the hardware is in a different state. That’s very bad! Here’s an example that I documented for myself yesterday:

Is this issue affecting iOS or Android (or both)?

I only have a Nokia 7.1 cellular telephone running Android 10. Again this is my very first attempt with the new Blynk and as simple of a hardware project that I can think of.

Looks like a bug. I filed an internal ticket for investigation. Thanks for reporting!

Good… didn’t think it was a feature…hee hee