Help setting up a google home with blynk and Nodemcu esp 8266

I am trying to turn an led on a breadboard on and off it works though my google home however it doesn’t seem to work but through my phone it does. I’ve tried to double-check that I am using the correct IP address when I ping the website. Nonetheless, it still doesn’t seem to be working. I am using pin D2 on the NODE ESP-8266 and have kept this convention throughout. I am using IFFF the google home will accept the command and give the correct pre-recorded however no switching on or off of the led through the relay as it works fine through the phone. Am I using the incorrect pin? Does the pin on the GET syntax reference the pins on the board or something else? It is 5 am and I am really trying to get this working before later this afternoon…

Any help is much appreeciated.

I am now using pin d3 on the board thats why I have change it to D0 instead…on the url

The best way to test your API commands is to paste them directly into the address bar of your browser. That way you get a meaningful response in your browser. If that’s an “invalid token” message then it’s pointing you in the right direction.

To figure-out if you’re using the correct server URL then type:
In your browser (obviously replacing ServerIP and Blynk-Auth-Code with valid values). If you get a JSON response with data about your project then all is good.
If you get an invalid token message then either the IP or your Auth code is wrong.