Got Error On My Datastream

Hi everyone,

I tried to add value to my datastream through url
( )

but what I get in return is this
{“error”:{“message”:“No datastream setup for that pin.”}}

I have setup datastream accordingly. It is there.

can someone help me with this problem. thank you in advance.

Hello. Looks like you created digital datastream, but in API you call virtual datastream:

You need to recreate the DS and make it virtual.

I have tested virtual but it is still not working, btw how to call digital datastream through API ?

Some screenshots might be useful.


Hi Pete,

here are my virtual datastream setup and the result trying to execute the API

What happens if you edit the datastream and change the data type to Integer?


same result, I just got white blank page,
if I use this button I can control my LED just fine

Hello, @amiruuu please explain again

1. Now HTTP API update value for pin is working for you?

It is correct. This indicates that the request is correct and the value has been updated.


In this screenshot, your datastring is a string. Do you need a string value?


What type of datastream do you have in this your widget? (LED title, switch widget)

And what you mean ‘blank page’? Blank page is displayed in page after click your LED title (swith widget)?

You are attempting to update a virtual datastream, and your datastream is digital. That won’t work. You have to change “v4” to “d4” in the URI to update a digital datastream, or “v4” to “a4” to update an analog datastream.
Your URL should look like this

@amiruuu empty screen on your API request screen means that DS has no value. SO you need either to set the default value or update the DS with some value to be able to see it in the response.

Hi @Oleksii-QA , what I am trying to do is use this HTTP API to switch on an LED for my ESP32, before this I got this error {“error”:{“message”:“No datastream setup for that pin.”}} because I use v2 instead of d2 because of my datastream setup as digital datastream, but now I have use the proper API that @John93 mention but I still can not turn on my LED, it looks like there is no communication between my HTTP API and ESP32.

thank you @John93 for your explanation, it helps me a lot to understand how it works, but still after I change it accordingly I still can not communicate with my ESP32.

Posting your whole sketch might help.

1 Like

The documentation for the REST API seems to imply that it only works with virtual datastreams…

I never use digital datastreams, so have no experience of using the REST API that way, but if it were me, I’d stick to testing with virtual pins - at least to begin with.

It’s normal for the web browser screen to be blank after an update API call.


1 Like


It works for me with digital pin, correct link -
Datastream setup -

Dmitriy from Blynk


In that case the REST API documentation ought to be updated so that it doesn’t just specify virtual pins.


1 Like

Thanks everyone , I can use the API now , thanks for all your guide I really appreciate it.