Getting the same compile error, BlynkTimer does not name a type

I am trying to get the example that shows how value can be pushed from Arduino to
the Blynk App to compile.
However, I keep getting the same compile error, BlynkTimer does not name a type.
My thoughts are the library, I have latest library but notice the BlynkTimer is separate from BlynkSimpleEsp8266.h in a folder called Blynk. Should this mean a separate include statement is required to make the example code work?

Not tried it yet but nobody else seems to have mentioned the compile fault I keep getting with latest libraries.

Thanks for any help.

Probably because it is a coding issue not library issue. Or you have some corruption in your libraries.

Please clear out and reinstall all Blynk libraries manually, not using the import .zip or “auto update” option as some issues can happen.

How to install Blynk library.

:point_up: Blynk library should be installed manually

Follow the instructions:

Thanks Gunner,
I had tried reinstalling the libraries before you suggested it to no avail. However, I thought I would give it another go and this time the compile error had moved further into the code but with a similar ‘type’ error for my timer. This time though it was obvious what was wrong as I was not being stumped at the BlynkTimer timer; declaration. Foolishly I had not complimented the timer.setInterval(1000L, myTimerEvent); statement with the relevant function he he!
Now working fine but much appreciated your response and as usual discussion has helped solve the problem.


1 Like