Getting started; Confirming non-corrupted IDE and Installing Blynk Libraries into proper location

I just saw the shield as a quick way to deal with the 3.3v power and the level conversion. No real smarts going on inbetween.

I don’t think they make a 3.3V Nano so you will be feeding 5V into the RX pin of the ESP01 (designed for 3.3V) unless you have a voltage divider on the line.

Directory screenshot?

This is where I say "then why you here" :stuck_out_tongue: … but in truth, there can be many hidden issues… just keep following @Costas

The shield has a 3.3v regulator to power the ESP8266 and voltage dividers for the RX line.

1 Like

Screenshot shows you have a libraries folder inside the libraries folder. What’s in there?

@radeohedca try to post now as we have increased your trust level.

Thanks Costas… yes, I got locked out as a new user limitation.
Oddly, that libraries directory within the higher libraries directory is empty and if I delete it, it reappears when I run the compiler. Clue ?

Don’t know why that is.

In the IDE try to remove Blynk.

Then close the IDE then remove all the Blynk libraires manually.

Install them again from the master zip file and reopen the IDE. Hopefully it will then compile.

Think I fixed it but still getting some errors.
I had the sketchbook location set to: C:\Users\Hugh\Documents\Arduino\libraries I changed it to: C:\Users\Hugh\Documents\Arduino then things started happening.
Here are the compiler errors I’m getting now…

WARNING: Spurious .github folder in ‘Adafruit NeoPixel’ library
avr-g++: error: missing filename after ‘-o’

exit status 1
Error compiling.
WARNING: Spurious .github folder in ‘Adafruit NeoPixel’ library
WARNING: Spurious .github folder in ‘Adafruit NeoPixel’ library

Presumably you are not using NeoPixel so manually remove the library folder for now. You might need to restart the IDE.

Less errors but still seeing this…

Arduino: 1.6.6 (Windows 10), Board: “Arduino Nano, ATmega328P”

avr-g++: error: missing filename after ‘-o’

exit status 1
Error compiling.

You have corrupted your IDE installation somehow.

I would do a fresh install of the IDE to new directories like C:\ArduinoNew\ and maybe even Google for “Portable Arduino”. That way you get to keep your broken IDE and maybe you can repair it later.

My version of the IDE is a bit old so I think I’ll take this opportunity to download and install the latest version. I have to pop out for a while but may be back a bit later. If I don’t return tonight then I’ll be back on tomorrow. Thanks for your help.

It’s compiling now !!
Installed the latest IDE and all seems well.

I had to create a new Blynk project and request another authorization token. Seems to take quite a while to get one so I won’t likely get it until tomorrow.
Thanks again.

1 Like

You can also just refresh the Auth (to a new one) or simply re-email the existing one, for an existing project (in the My Devices section of your project)…

The time it takes for the email to arrive is more likely due to your email provider, internet, angle of your tongue etc… I use Gmail and it can be anywhere from near immediate, to a few minutes later.

EDIT - Might as well mention for anyone else looking… but clicking or long pressing on the starred out dark blue token will add the whole token into your device’s clipboard for transfer elsewhere via Dropbox, Google Drive, Google Keep, etc… or since I also use emulators on my PC, I can directly copy/paste the Auth from emulator into IDE.

Now the difficult part starts. Setting the baud rate of the ESP01 with AT commands etc.

Same here but I think @radeohedca might be using hotmail.

I got the token !
I’m familiar with the Hayes AT derived command set… looking forward to getting into the nitty gritty ! Have to go out now. Thanks again.