BLYNK
BLYNK.IO       📲 GETTING STARTED       📗 DOCS       👉 SKETCH BUILDER

Getting error while compiling library BlynkSimpleEsp8266.h:18:21 no such file or directory even installed library

I added the library as guided on the process for manual inclusion of library to the sketchbook folder but still while compiling getting error BlynkSimpleEsp8266.h:18:21: fatal error: version.h: No such file or directory.Kindly guide how to fix same

Not something we can fix here… All you can do is clean out the current Blynk libraries and try the manual install again… paying close attention to where they go in your IDEs library structure.

I had followed the article only but the ide doesn’t detect blynksimpleesp8266.h library it finds blynk.h and blynkesp8266_lib.h

Well, it is in my copy :slight_smile:

I don’t know what you are doing differently in your install… or even what you are trying to load that causes this error… so not sure what else I can suggest.

Yes I have same to , but I don’t know why it’s inclusion not working as earlier it did worked.In arduino ide also the particular header file is not shown other blynk file like blynk.h and blynkesp8266_lib.h are shown

Thanks all issue resolved as had to remove old packages manually

1 Like

Dears
i have same issue i remove and install library many time and same result it give
n file included from H:\Hobby\Electronic\Micro\ESP8266\Project\Test\Fish_Tank\Fish_Tank.ino:37:0:

C:\Users\hady.ahmed\Documents\Arduino\libraries\Blynk\src/BlynkSimpleEsp8266.h:18:21: fatal error: version.h: No such file or directory

I’d suggest that you create a new “need help with my project” topic and provide full answers to ALL of the questions that you are asked when you do this.

Pete.