Faled to disable echo

i want to control the robot using wifi…
but at serial monitor of my arduino IDE i got this msg.
.how can i resolve it?

[19] Blynk v0.3.4
[520] Connecting to D-Link_DIR-600M
[1537] Failed to disable Echo

I’ve seen this discussion plenty of times, there should be lots of info in the forum for you already if you use the search. :+1:

1 Like

so i want to upload firmware?

I was mostly suggesting that there has been a lot of discussion on the forum about the same error. Have you searched and read through the old threads? I’m guessing that your questions will have been answered already.


plzzzz help me yar my blynk app. also display this message “arduino not in range”:sob:
why this?/???
my esp8266 connected to wifi bt blynk not connected?:disappointed_relieved:

@Pranjal123 have you read all the threads containing “failed to disable echo”?

Have you read all the Blynk documentation?

Your first post shows an old Blynk library that wouldn’t work anymore as the server url was changed. Ensure you are using the latest FOUR libraries required to use Blynk.

Do you really need an Arduino connected to the robot as connecting an ESP is generally much, much easier?

If you are still having problems then let us know which Arduino, which ESP, which IDE, which OS, and which Smartphone you are using. Don’t go beyond version 1.6.9 of the Arduino IDE as there are reports of problems with 1.6.10.

arduino uno
version 1.6.9 of the Arduino IDE
windows10 OS
Asus Zenfone 2 Laser ZE550KL
connections check by me several times… my esp get connected to my wifi router bt still dont get success to connect with blynk…

in my mobile no such network is display as at thinker and all… is esp266 create its own network?

There’s also some info here: https://github.com/blynkkk/blynk-library/wiki/ESP8266-with-AT-firmware


I also made a small project, a plant monitor and got the “Fail to disable echo” problem when I use an Uno, not when I use a Nano.

My solution:
Use D10/D11 instead of D3/D4 for the TX and R0 connections, this will also solve NAN errors of the DHT11/DHT22 sensors.

Also use a steady external powersupply, the Arduino 5V and 3.3V are often instable.



1 Like

esp 8266-01 baudrate must be  9600

esp 8266-01 baudrate cmd 

AT+ UART_DEF=<baudrate>,<databits>,<stopbits>,<parity>,<flow control>

next edit code 
// Hardware Serial on Mega, Leonardo, Micro...
//#define EspSerial Serial1

// or Software Serial on Uno, Nano...
#include <SoftwareSerial.h>
SoftwareSerial EspSerial(3, 2); // RX, TX

// Your ESP8266 baud rate:
#define ESP8266_BAUD 9600

@praveen36111 This is an old topic… .And you are posting your code for what reason?