"ESP8266 was added to the list of hardware" in app update

I am curious about what is meant by “ESP8266 was added to the list of hardware” when you updated the blynk app recently. Wasn’t it already supported as a standalone? Does this then mean that it is supported as a wifi module for the arduino uno?

No, it was a bug about ESP8266 Standalone.
Regarding the ESP as a module for Arduino… :smile: just implemented it in BETA:

1 Like

Great news! Do you know when Blynk will be compatable with wifi networks that don’t require a password?

Approximately in a week, i think :slight_smile:

Great! I must say, the Blynk team is doing a fantastic job with customer care. I know you are all very busy and I really appreciate you all taking time to answer our questions :smile:


Just to clear up the original question: It just means that when you select hardware when setting up your dashboard you now have ESP8266 as an option. Before this release you had to choose Uno.

1 Like


since I dont get my Wifly 171 to work, I started testing my ESp8266 today.
Disappointing - did not get it to work…

My setup:

  • Arduino Mega
  • ESP8266 connected with TX, RX, 3.3v and GND
  • connected to Serial1
  • Sketch from examples

Upload worked. ESP8266 status LED:red and blue LED are ON (no blinking, nothing else)
Application cant connect

Please help me someone out…

tried out this:
Changed Firmware to 18 (instead of 22) => nothing
Connected CH_PD also to 3.3v => blue LED is now blinking every 10-20 secs, nothing else working though

@currymuetze, please try running ESP8266 library examples first, to see if the connection is working, conceptually.
I mean the original ITEADLIB_Arduino_WeeESP8266 from this repo: https://github.com/itead/ITEADLIB_Arduino_WeeESP8266
[Note that Blynk uses a modified one…]

currently I am trying to update firmware - but doesnt work…
I really thought all this stuff is pretty much PlugnPlay with blynk :wink:

ESP8266 is not an easy one… you need to provide enough power for it (stable 3.3v 500mA recommended).
Maybe this is a problem…

@currymuetze what module of esp8266 are you using? There are different approaches to the board. e.g. Esp8266-03 needs one pin High and another low to run. Tell me what board you have and i might be able to guide you :slight_smile:

I use esp-01, as shown here:

Same problem on esp8266-01 (to Uno). Serial monitor type “…”.
I take a few days for this… :frowning:

This morning I reflashed an esp01 with latest AT firmware. I’m pretty sure it defaulted to 115200. What are you using. I’m pretty sure I needed to change it in the example sketch as well (I think it was expecting 9600).

I’m not near my machine now to check, just mentioning something to check.

Thanx…but I dont have the programing board for esp8266… :frowning:

Yeah, but I wasn’t talking about flashing the chip as the problem. My point was that after I freshly flashed a chip, the default baud for communicating with AT commands was 115200. This threw me at first since the blynk sample was initializing EspSerial with 9600 in the example. I changed it, helped me. For all I know I’m using out of date firmware, I really was just trying to mention baud as something to check.

1 Like

Do you mean the breadboard adapter? You don’t need it. Male to female jumper cable work as well if you have those.

I dont understand. How I connect esp8266 to USB?

You connect the esp to the arduino as noted in the tutorial and connect the arduino using the usb

1 Like

connect to arduino as USB to Serial not always work i tried many times on different computers with different Power Sources and all failed .

today i received my USB to Serial adapter - three of them with all available chips - i hope that works as i spend on parts and shipping more than 150 USD and every thing depending on ESP-01 to work.