BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

ESP8266 Thing Dev board won't go online


#1

Greetings Blynkers;

So this is my first post here, although i have been searching the forum and tearing my hair out for about a week now.

I have made a universal remote relay using a Sparkfun ESP 8266 Thing dev board and it all works fine after I flash the code to it. It goes online fine, serial debug shows all the desired feedback on running even the working examples. However, as soon as I unplug the USB from my laptop and plug into any other source - or even replug into the same laptop, it goes offline and will not go back online.

I have tried all kinds of sketches and configurations, to no avail. I can’t flash the device and leave it plugged to my laptop indefinitely, I need to be able to power it from another source, but it seems to require a “kick in the ass” flashing to get it online. Any idea what could be going on?


#2

That sounds odd.
What things do you have connected to the board? Some pins need to be in a certain state at boot-up otherwise it either won’t boot, or Wi-Fi wont be enabled (which could cause the device to appear dead if you’re running Blynk code and using Blynk.begin as that will block the execution of any other code).

GPIO 0, 2 and 15 are the pins to look out for, as devices connected to these pins could be pulling them up/down at boot time.
Read this for more info:

Pete.


#3

Hello Pete! Thank you for your reply.

I do indeed have one lead on GIPO 0, the other is on 4. Should i remove the one on 0?


#4

Yes, try it and see what happens.
If that doesn’t work then unplug everything and see how the bare board behaves.

Pete.


#5

I’ll give that a try and let you know shortly.


#6

Hello again Pete!

So the LED on pin 0 was indeed the problem. It has since been moved to 5 and works flawlessly! Thank you so much!


#7

You’re welcome - glad my instincts were right.

I’ll mark the topic as ‘solved’.

Pete.


#8

Thanks again!