ESP8266 Problem

I am using the softserial example to use esp8266-01 as a wifi shield for my arduino uno. I have made the connections but I am facing these problems.

  • Sometimes I get Failed to disable Echo.

  • Sometimes I get failed to set STA mode.

  • The hardware also gets disconnected very easily.

  • Sometimes it shows Invalid HW cmd: pl

  • I get a lot of Login Timeout messages.

I am using 115200 baud rate. I tried other but my esp is responding only on that rate.

I have been struggling for some weeks now. Any help will be appreciated.

1 Like

You should try a lower Baudrate. The reason you ESP is only responding to that value is because it’s programmed that way.

If you hook up the ESP to a serial convertor on your PC you can set the Baud rate to a lower value with an AT command. Depending on the when it was made there are, I believe, two commands to do that.

That is one, or this one:

Different command, but same effect

Which baud rate is favorable? 9600?

That is definitely where I would start. That should work really stable. If you need more speed you can always go up, but I don’t think that’s really needed for this kind of construction. Everything in my house works fine with 9600 :slight_smile:

Thanks a lot :slight_smile: It’s working now :slight_smile:

The baud rate was the problem. But i am still getting failed to disable echo

I’m not sure what that problem could be, but it may have to do with the firmware version. I think @vshymanskyy can recommend a good firmware, I’m not sure what I’m running (besides, I’m running the ESP-01 which is notoriously unstable anyway).

Are you feeding your Esp from your Arduino? This could be the problem. Use an external power supply for the Esp.

All new modules ESP-01 I have had the same problem. To communicate with
ESP I used hard serial of UNO and libraries ESP8266_HardSer.h
BlynkSimpleShieldEsp8266_HardSer.h with 115k speed
I the problem solved by setting the pre-configuration of the ESP program by “ESP8266 Config.exe.”
I set operating mode = STA and put a name and password for the network to connect ESP.
From that moment all ESP work properly in projects.

can you please explain in detail what you have done. i’m stuck with the same situation of getting failed to disable echo error

@muhammed_sabiq. This topic is 9 months old.

There have been many, many, varying solutions to that error that depend on your exact situation with your hardware.

Please search this forum for the words “failed to disable echo” and try all the solutions shown on SOLVED topics. If you still have issues then please create a NEW topic of your own, showing all the details like hardware type, firmware versions error messages and solutions tried.

Thank you.