BLYNK
HOME       📲 GETTING STARTED       📗 DOCS       ❓HELP CENTER       👉 SKETCH BUILDER

Esp8266 nodemcu v3 With blynk


#1

Hi,

My NodeMCU is getting disconnecting again and again. please help

I am using the basic ESP8266 Standalone Sketch in Arduino IDE

Below is my serial port data

  >     >   ___  __          __
>     >    / _ )/ /_ _____  / /__
>     >   / _  / / // / _ \/  '_/
>     >  /____/_/\_, /_//_/_/\_\
>     >         /___/ v0.4.3 on NodeMCU

>     > [5001] Connecting to blynk-cloud.com:8442
>     > [5732] Ready (ping: 11ms).
>     > «ÂýÀšKüþ[83] Connecting to xxxxxxxxx
>     > [3084] Connected to WiFi
>     > [3084] IP: 192.168.0.5
>     > [3084] 
>     >     ___  __          __
>     >    / _ )/ /_ _____  / /__
>     >   / _  / / // / _ \/  '_/
>     >  /____/_/\_, /_//_/_/\_\
>     >         /___/ v0.4.3 on NodeMCU

>     > [5001] Connecting to blynk-cloud.com:8442
>     > [5621] Ready (ping: 5ms).
>     > (ZãÕ�4=‰ø[83] Connecting to xxxxxxxxx
>     > [7084] Connected to WiFi
>     > [7084] IP: 192.168.0.5
>     > [7084] 
>     >     ___  __          __
>     >    / _ )/ /_ _____  / /__
>     >   / _  / / // / _ \/  '_/
>     >  /____/_/\_, /_//_/_/\_\
>     >         /___/ v0.4.3 on NodeMCU

>     > [7152] Connecting to blynk-cloud.com:8442
>     > [7851] Ready (ping: 7ms).
>     > «Âý¡šz9ò[82] Connecting to xxxxxxxxx
>     > [7083] Connected to WiFi
>     > [7083] IP: 192.168.0.5
>     > [7083] 
>     >     ___  __          __
>     >    / _ )/ /_ _____  / /__
>     >   / _  / / // / _ \/  '_/
>     >  /____/_/\_, /_//_/_/\_\
>     >         /___/ v0.4.3 on NodeMCU

>     > [7152] Connecting to blynk-cloud.com:8442
>     > [7832] Ready (ping: 10ms).
>     > ¨˜{û¡šz9òÿ[82] Connecting to xxxxxxxxx
>     > [7083] Connected to WiFi
>     > [7084] IP: 192.168.0.5
>     > [7084] 
>     >     ___  __          __
>     >    / _ )/ /_ _____  / /__
>     >   / _  / / // / _ \/  '_/
>     >  /____/_/\_, /_//_/_/\_\
>     >         /___/ v0.4.3 on NodeMCU

>     > [7152] Connecting to blynk-cloud.com:8442
>     > [7817] Ready (ping: 7ms).
>     > «¢ÿÀrþ|þþ[83] Connecting to xxxxxxxxx
>     > [7584] Connected to WiFi
>     > [7584] IP: 192.168.0.5
>     > [7584] 
>     >     ___  __          __

#2

Hie i had same problem before all you need to do is turn your router off wait for 5 min then try should work


#3

HI

I have same your problem.

Please hlep me.

I using Witty cloud board.


#4

did you go over troubleshooting guide? USB cable, power adapter, etc?


#5

Hello.
I had a problem similar with Nodemcu V3 that I bought and the solution was remove one diode and do a direct connection, this has resolved my problem.


#6

I guess it’s the problem with

** Connecting to blynk-cloud.com:8442**

I guess the library is updated but it shudnt show this


#7

That’s exactly what it should show, why do you think it should say something else?


#8

Sorry got confused with this


#9

Yes i have used a different USB cable, as well as a different module also, but no luck.


#10

Yep, have tried this but no luck.


#11

Well make sure u r using latest arduino ide
Make sure u using latest library
Update u4 android app
Make sure to select correct board node mcu 1.0 from board manager


#12

Your problem is due to library issue update ur library


#13

Hey. Tell me, what is affected by the diode, which is now in place a jumper?


#14

I am using the latest library


#15

if I’m not mistaken, latest library 0.4.4


#16

No you are not.


#17

Thank you for reply i have updated to 0.4.4 it shows the same


/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
/
//_, /////_
/
__/ v0.4.3 on NodeMCU

I had updated the Arduino IDE now it working fine. Guess it was problem with IDE, have updated to 1.8.1.

Thank you everyone .


#18

If you did the upgrade correctly the graphics should show 0.4.4 not 0.4.3.

You can’t do the Blynk upgrade in the IDE. Close the IDE. Copy, don’t move, the 0.4.3 library to somewhere for safe keeping. Delete 0.4.3 from the original location and paste in 0.4.4.

You will encounter more problems if you don’t use 0.4.4.


#19

Haha told u bro library issue


#20

Thank you.

When i use simple timer giving the same problem ie it is getting reset .

I am using the below code

_> #define BLYNK_PRINT Serial    // Comment this out to disable prints and save space_

_ > #include <ESP8266WiFi.h>_
_ > #include <BlynkSimpleEsp8266.h>_
_ > #include <SimpleTimer.h>_

_ > // You should get Auth Token in the Blynk App._
_ > // Go to the Project Settings (nut icon)._
_ > char auth[] = “xxxxxxxxxx”;_

_ > // Your WiFi credentials._
_ > // Set password to “” for open networks._
_ > char ssid[] = “xxxxxxxx”;_
_ > char pass[] = “xxxxxxx”;_
_ > SimpleTimer timer;_
_ > int hum = 7;_
_ > int relay = 8;_
_ > int humstate;_
_ > void ReadData();_
_ > void setup()_
_ > {_
_ > Serial.begin(9600);_
_ > Blynk.begin(auth, ssid, pass);_
_ > pinMode(hum, INPUT);_
_ > pinMode(relay, OUTPUT);_
_ > pinMode(0, OUTPUT);_
_ > pinMode(1, OUTPUT);_
_ > pinMode(2, OUTPUT);_
_ > pinMode(3, OUTPUT);_
_ > timer.setInterval(1000L, ReadData);_
_ > digitalWrite(0,LOW); _
_ > digitalWrite(1,LOW); _
_ > digitalWrite(2,LOW); _
_ > digitalWrite(3,LOW); _
_ > }_

_ > void loop()_
_ > {_
_ > Blynk.run();_
_ > timer.run();_
_ > }_
_ > void ReadData()_
_ > {_
_ > humstate = digitalRead(hum);_
_ > if (humstate ==1)_
_ > {_
_ > digitalWrite(relay,HIGH); _
_ > Blynk.virtualWrite(0, “LOW”);_
_ > }_
_ > else_
_ > {_
_ > digitalWrite(relay,LOW); _
_ > Blynk.virtualWrite(0,“HIGH”);_
_ > }_
_ > }_

Without timer it is working fine.

I am using the updated library now…