ESP8266 looping while trying to connect to the blynk servers

Hi, I’m tryng to connect my esp8266 to the Blynk servers. The esp8266 is connected to the Arduino Uno. I followed this tutorial (Program ESP8266 via Arduino UNO) to upload a sketch to the esp8266 because I haven’t an FTDI to communicate to Arduino, but only a usb cable; and also I got stuck beacuse the Arduino IDE displayed some errors every time I tried to upload something. I don’t know if the wirings are correct for a right functioning of the wifi module, but the uploading part works fine.
When the upload of the sketch is complete I open the Blynk app and when I run the program it says “your esp8266 is not in network”. I enabled the serial debug and in the Serial Monitor appears this code:
ùþÚÕ8] Connecting to chimutingruppa [1060] Connected to WiFi [1061] IP: [1061] Blynk v0.3.8 on ESP8266 v€ÉYbKÿâcü´UÂê�Connecting to chimutingruppa [1060] Connected to WiFi [1060] IP: [1060] Blynk v0.3.8 on ESP8266
and it continues infinitely, until I remove the power.

So it loops and doesn’t connect to the Blynk servers and I’m unable to use the app. I’m using the Esp8266 Standalone example sketch.
I’m a newbie with Esp8266 and Blynk, so please help me with this, also beacuse in internet I haven’t found anything.

P.S. sorry for my bad english

You are using the wrong sketch, standalone is for an ESP without an Arduino.

There are other sketches with ESP as a WiFi shield but to be honest it is a bit of a nightmare for many using ESP as a shield.

There is almost nothing that an ESP can’t handle that an Arduino can do, so if I were you I would use the wrong sketch you are using and forget the Arduino.

Do you have a “real” ESP or the VERY limited ESP01?

OK, I understand that I should use the shield sketch, but why did you say “very limited esp01”? I’m wondering this because I bought the ESP-01 version.
The problem is that I haven’t an FTDI, so I cannot upload a sketch directly, and I need an Arduino. Also I want to use Arduino as a controller of various sensors in a project in the future, and the Arduino microcontroller is crucial

The Wemos D1, for example, is much more versatile than a single ESP01. It has the FTDI on board so you don’t use that, it can be programmed with the Arduino IDE and it has much more memory.

Only disadvantage, it has only one analog port. Other than that it’s superior to the Arduino platform. And it’s much smaller :slight_smile:


It does everything, I2C, Interrupts, the whole Arduino/AVR thing :slight_smile:

The ESP01 only has 2 pins compared with a dozen on a decent ESP.

Some ESP01’s have 512KB and some 1M.

Decent ESP’s now have 16M (although you can only use the first 1M for sketches, the other can be used to hold data of various kinds).

In what way is the Arduino crucial? See @psoro’s post on the WeMos site at to see how easy it is to provide 4 analogue ports.

1 Like

or… you can even see the ADS1115 running with Blynk here :wink:


Thank you guys. When I bought the esp8266 I didn’t know the difference between the esp01 and other ESPs, and you clarified me that. But for the moment I have this version, so I’m going to try everything to use the Esp8266 01 version as a WiFi modem for Arduino.

Ok doki… in this case, make your life a little bit easier… Buy an USB to TTL converter like this for 0.50€

And do this Schematics:

This way you will be able to Flash your ESP with the AT firmware to use it as Shield or directly as Standalone.


When I looked for an FTDI on internet(I think this is the other name of the USB to ttl) I saw a price of 5€ (maybe I don’t remember well), but now that you say it costs 0.5€, I think I will buy one of these. Thank you

You can find the converter HERE for example but if look at ebay or AliExpress you will find several shops to buy it.