ESP8266 is connecting to wifi and isnt showing in blynk app

Hi. I loaded the default Edgent_ESP8266 example and when I upload the code to the esp it doesnt show up in blynk or wifi settings.

This is what I get in Serial Monitor:
___ __ __
/ _ )/ /_ _____ / /__
/ _ / / // / _ / '/
//_, /////_
__/ v1.0.1 on ESP8266

[388] --------------------------
[391] Product: garage auto
[393] Firmware: 0.1.0 (build Feb 7 2022 22:02:20)
[398] Token: …_tHW
[400] Device: ESP8266 @ 80MHz
[403] MAC: DC:4F:22:7E:39:21
[406] Flash: 4096K
[408] ESP core: 3.0.2
[410] ESP SDK: 2.2.2-dev(38a443e)
[413] Boot Ver: 2
[415] Boot Mode:1
[416] FW info: 467936/1626112, MD5:dbbfc0a01dada274ca2e29f1974795cb
[623] Free mem: 31272
[624] --------------------------
[625] Connecting to WiFi: MySSID
[7890] Using Dynamic IP:
[8102] Current time: Mon Feb 7 18:13:18 2022
[8103] Connecting to
[10541] Redirecting to
[10553] Current time: Mon Feb 7 18:13:20 2022
[10554] Connecting to
[11975] Ready (ping: 12ms).

You need to explain more.
What does your sketch look like? (Post the code correctly, using triple backticks, which look like this: ```).
What provisioning process did you go through with the app?


Just the regular example from Blynk library

[Unformatted code removed by moderator]

After this uploads I reset the esp8266 and go to blynk app. I press “Add Device” then “Connect to WiFi” and when its scanning the networks my esp isnt there. Same with the manual connection. I hope this information helps.

Thanks for answering!

I reminded you of the need for triple backticks when posting code, and even provided you with some to copy/paste, but it seems that advice fell on deaf ears.


// Fill-in information from your Blynk Template here
#define BLYNK_TEMPLATE_ID           "My Template ID"
#define BLYNK_DEVICE_NAME           "My Device Name"

#define BLYNK_FIRMWARE_VERSION        "0.1.0"

#define BLYNK_PRINT Serial
//#define BLYNK_DEBUG

#define APP_DEBUG

// Uncomment your board, or configure a custom board in Settings.h
//#define USE_WEMOS_D1_MINI

#include "BlynkEdgent.h"

void setup()


void loop() {;

bad English sorry

How many characters in your BLYNK_TEMPLATE_ID and your BLYNK_DEVICE_NAME ?


12 in template id and 11 in device name

Press the Flash button for 10 seconds to clear the stored credentials, or re-upload the sketch with Tools > Erase Flash > All Flash Contents selected.


Thanks for the advice but I already tried it. Actually let me tell you some info that may be helpful. I had an account and the esp was actually working. Then I wanted to add another phone(it is a old phone) and when I tried to login it didnt login(even tho mail and password were right). Then I pressed sign up on that phone and typed the email I already used for registration. It somehow worked. After that on my new phone it logged out automatically. I used the the link that I got for registration and created a new account. Thats when my esp stopped working(even when I uploaded a new sketch with new template id). Sorry for this much text and for your spent time but I think this info really may be helpful

It sounds like you have two accounts, and that the phone you are using to do the provisioning is logged into a different account to the one that the the template belongs to.